"There is no request token for this page", has anything changed in the API?


#1

Getting the following error out of the blue:

There is no request token for this page. That’s the special key we need from applications asking to use your Twitter account. Please go back to the site or application that sent you here and try again; it was probably just a mistake.

Anything changed in the last few hours?


#2

We are seeing massive issues all across the board, everything is failing at the moment. :frowning:


#3

Similar here, we are seeing the oauth get request token failing, though it seems to be trying to do a redirect on it now rather than a direct response. Has the URL or behaviour here changed? The standard ruby OAuth lib can’t seem to deal with getting a redirect, if that is indeed what is happening.


#4

Ah. So it’s not just us? I thought it was because of our changes lately. We keep getting these same error since last night. What is the issue?


#5

Anyone?


#6

We had an issue that caused this yesterday, but I believe it should be fixed or minimized now. Are you still experiencing it?

If so, can you share the steps you’re taking throughout the sequence – specifically the URL you have when you get to oauth/authorize or oauth/authenticate? (Validate that you’re in fact including an oauth_token on that step and that it’s one you retrieved from the previous oauth/request_token step)

Thanks!


#7

Hi @episod

I am using https://api.twitter.com/oauth/authenticate and yes I am including the oauth_token

public function get_auth_url()
{
$token = $this->get_request_token();

return $this->auth_url.'?oauth_token='.$token->oauth_token;

}

This happened completely out of the blue, the app was working fine. Nothing was changed our end, so its definitely something your end.


#8

Submission is in moderation.


#9

I am getting this error when Autherising after login in my android app “TwitterException{exceptionCode=[764db2f2-027c96ee], statusCode=-1, retryAfter=0, rateLimitStatus=null, version=2.1.11}”.
Any one Please help me.


#10

@episod Still experiencing the issue today. And this is the link I get:

https://api.twitter.com/oauth/authenticate?oauth_token=lidNp5WpmCMIXcVPqgxUbwBH1YCccSt651p5cOs

and when I get redirected to above link, that’s the time I get the same error on first post.


#11

Alright. We’ve successfully fixed ours. I don’t know if this is totally related with the others issues. We’ve recently changed from http to https (SSL stuff) and it was when this first happened to us. We’ve checked our code now throughly and we found out in our callback we’re doing this

redirect_to request.env[‘HTTP_REFERER’] || env[‘omniauth.origin’] || root_url (ruby and using omniauth-twitter https://github.com/arunagw/omniauth-twitter)

We removed request.env[‘HTTP_REFERER’] and it worked perfectly now. I think it is right that we really shouldn’t have had HTTP_REFERER there but it is weird that when on http-version HTTP_REFERER doesn’t have a value and when on https-version it does have a value. Also, on https-version some of us can log in and some really can’t. So I think that HTTP_REFERER sometimes has a value and sometimes don’t. Different behaviors, which is a bit weird.

Would you happen to know why @episod?

I don’t know if this’ll help anyone but it’s still worth checking.


#12

Waiting for your reply…


#13

Web browsers strip the HTTP Referer header when using HTTPS, so that’s a likely explanation why this broke down for you. Interesting but unfortunate choice to leverage the header for that redirect process.