The search web page has set different restriction from mobile to desktop


#1

I checked and still not sure what category to file this,
so I will put it here. Hope it’s right place.

The thing is, the twitter search URL seems has different restriction/response from desktop
to mobile, which cause incorrect behavior (to me).

Take this url for example, “http://twitter.com/search?q=%23RunninRebels”,
This is the url returned from the API "https://api.twitter.com/1.1/trends/place.json"
If I haven’t log in and used this url in the Desktop browser (take Chrome here as sample),
it works fine and show me the search result in both incognito window and normal window.

However, on the mobile platform (here take iOS as example),
I use safari to open it (I have not login) and all I got is a circle which spins forever.
I think it’s wrong, it should at least take me to the login page or some other page
instead of let me wait here.
Check this out.

If I use Chrome (on ios) to open this link,
in normal mode and I have been login and log out before.
it somehow seems work correctly but sometimes not.
I am not sure why.
And if I use incognito window mode to open it (not login in),
I will either still get a spinning forever circle or the following page,
which is incorrect for me too.


It’s the same link as listed above.

I know the link "https://twitter.com/search?q=%23RunninRebels"
will be transfer into mobile one "http://mobile.twitter.com/search?q=%23RunninRebels"
automatically. Still, It doesn’t work.

One more thing for your reference,
I am iOS developer and I found this error while I try to load this link in the UIWebView.
About a couples weeks ago, I can see the search result normally and correctly in my webview.
But recently it just show me a spinning around circle.

Hope these information is enough for debug.
Please let me know the progress or what I should adjust.

Thanks.


#2

These forums are mostly about API and Fabric related questions. So you might have more luck reporting this issue using the Support Form.
Note: You need to be logged in to see the form, else you will be redirected to the Support homepage!


#3

Thanks, I will try it.