The same .jpg Twitter allows for my account is not allowed for my dev.twitter settings


#1

Attempts to upload the same .jpg I use for my Twitter account is reject with the following response from Twitter:

It seems you did not upload a valid Image.
Only PNG, GIF and JPEG formats are supported.

The image I attempt to upload is the same image that my current Twitter account displays as follows:

file name: davidwbrown.jpg
size: 3.7 K

The Twitter dev page displays allowed image sized as: 700K

What to do?


#2

Hi geezenslaw,
I’ve received the same response uploading an image for my app. To solve it I’ve ignored the message and I’ve pressed other time the button to save the changes (in my case “Update this Twitter application’s settings”).

I hope that it helps you.
Bye.


#3

Strange, we also received the error, then scrolled down and clicked the Update button once more (even though the file was no longer showing in the upload section), and that worked.


#4

I encountered this issue last night and after several attempts of trying upper/lower case for PNG & JPG files, I found the solution to get the image updated was exactly as Stefano & iATN posted:

  • first: you browse to your image file and Update… the error message is returned
  • second: make sure the image file field is empty (IIRC the previous step blanks it out) and press Update… again, now the form will report success & you’ll see your new image file for your app

#5

Thanks for the solution. Encountered the same wierd problem.


#6

Just had this problem, and the same solution worked for me (Try uploading once, then click the update button again after it fails).


#7

same but it works after second press of upload


#8

Worked for me, too. Thanks!


#9

I used to be able to upload the image by clicking update again as described above, but recently that doesn’t seem to work either, and there doesn’t appear to be any way to upload a valid image (?)


#10

The solution @ImaCanuck posted DID just work for me.


#11

Worked for me too. Thanks


#12

Yeah, worked for me too. Crazy tho’ coz it can really bug someone who doesn’t read this post. Personally, I tried about 5 times, changing format from jpeg to png and even resized it then GOOGLED it! That worked!


#13