T.co links not working


#61

Only have access to Virgin/Optus for now.

Android, DNS Lookup (Oreophilus):

;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 18862

;; flags: qr ra ; QUERY: 1, ANSWER: 8, AUTHORITY: 0, ADDITIONAL: 0
;; QUESTION SECTION:

;t.co. IN ALL
;; ANSWER SECTION:

t.co. 86399 IN

t.co. 86399 IN

t.co. 899 IN NS NS4.P34.DYNECT.NET.

t.co. 899 IN NS NS2.P34.DYNECT.NET.

t.co. 899 IN NS NS3.P34.DYNECT.NET.

t.co. 899 IN NS NS1.P34.DYNECT.NET.

t.co. 29 IN A 199.59.148.12

t.co. 29 IN A 199.59.150.44
;; AUTHORITY SECTION:
;; ADDITIONAL SECTION:


#62

This happened to me in 2012 when using app via mobile network, assumed something odd with Optus australia network/ proxy settings, or yet another bug in my then Motorola Razr.

Is now happening again (still on Optus network, but service provider Amaysim), and to add to frustration, attempting to click through to shortened urls via Twitter is causing all my browsers to shit themselves. Nothing will load unless, apparently, I get hubby to log into google for me rathere than use myy account.

I am no tech savvy person. But this feels like censorship?


#63

Android client is still broken. Get ‘could not retrieve tweet’ error when clicking on any link from a t.co url.

Twitter app opens browser, which loads the t.co link, which tries to reopen the android client and fails.

Completely unusable in its current state on android at least.


#64

I’m having the same issue. When I shorten a link in Hootsuite and test it, it works fine, but when my post appears on Twitter and I try to click on the same link, I get the spinning “waiting for t.co message,” and am then told “this page can’t be displayed.”

The same issue is occurring with every link I try in both my and others’ posts, and it’s happening on both PCs and Macs, using both Internet Explorer and Firefox.

Has anyone found a fix for this issue? It’s making Twitter pretty useless for me.


#65

I’m using Mozzila Firefox and whenever i click on the link(t.co) it displays a "about:blank’’ page while spinning the loading circle, and while the circle is spinning in the bottom left it says ‘‘Looking up t.co…’’ and than it displays the standard Server not found message on which there are instructions on how to "maybe’’ fix the problem such as ‘‘Check the address for typing errors such as ww.example.com instead of www.example.com’’. It also says ‘‘Firefox can’t find the server at t.co.’’.

I hope that this clarified the issue, thanks in advance.

P.S. I’m using a PC.


#66

This just started happening to me today. Have not had a problem with it before. I’m also on a PC and recently upgraded Firefox. Suggestions for fixing this?


#67

t.co links are dead for me today.
I’m on android, and currently roaming abroad. I use Firefox on the android.
I’ll check on PC at home soon, and on my WiFi.

When I click a link, the page times out on the t.co link, with a “Request Timeout” message.
Picture previews, however, do work, so I can see resumes when tapping the tweet.


#68

I have had it fail regularly on my Android (Lollipop 5.0.1, Telenor SE) and now it fails on my broadband when it got switched to Bahnhof.se, both through my Android and through my iMac (Mavericks). This makes it impossible for me to follow links on twitter. Bah! Totally useless.


#69

And then suddenly it works through my Bahnhof.se broadband. I have no idea what is going on.


#70

ok. there is solution I think. don’t click the link just copy it and paste in new window no t.co but the link in tweet


#71

Reviving this old thread, I have had this issue for over a year on Virgin Mobile in Australia. t.co links never ever work. Is there an actual solution here?


#72

remove s from https-it works for me


#73

Three-and-a-half years and counting. Wow! T.co links resolve for me maybe 10% of the time.


#74

So frustrating! I was trying to link to my personal site and the links kept being broken somehow. I tried everything and finally by pasting the address with the back slash and “home” part of the address, it worked (example: http://www.carynmay.com/home)…for now! Fingers crossed!


#75

Just Get The Link From The iPhone. All You Have To Do Is Copy The Link From Your Text Message Box.
Part 1 Go On Your Google+Page Video And Use The Copy Link On Your Phone.
Part 2 Paste It To Your Text Message Box Or Clip Board
Part 3 Paste It To Twitter.

Works For Me:)
Enjoy Your Day Everybody


#76

Links via t.co only work for me maybe 10% of the time - mostly they just sit around and timeout.

This is using Virgin Media broadband in the UK.

Wouldn’t be quite such a problem if every link on Twitter wasn’t forced to go through t.co - as it is, you guys REALLY need to make sure this stuff works. It’s horrible.


#77

The number of replies and especially the hitcount shows that this is not a problem that plagues only a few people.
I have the same issues, t.co links just don’t resolve most of the time. If I let it sit around to timeout then highlight the navigation bar and hit enter, they usually load. They also work if I use just http without the secure layer. And it has been like this for a good while.

Using the latest safari, maybe that’s somehow related.


#78

Sporadic but consistent broken links from t.co

Safari Version 9.0.1 (11601.2.7.2)
OS X El Capitan 10.11.1

Error: Failed to open page | Server is not responding

After a couple of minutes of refreshing the link work.


#79

Same issue. Its happening with twitter.com sometimes.
I just added this to my hosts file to see what happens:
199.16.156.38 twitter.com
199.16.156.11 t.co


#80

I have the same problem & it is limiting my use of twitter severely. I’m using a Mac computer, perfectly updated & relatively new.