T.co links not working


#41

I have to apologise for being too hasty. Switching off, unplugging and rebooting seems to have fixed things.


#42

Have had this same problem for a week or so. Links seem to work fine when using the mobile twitter app, but when on a windows machine, using chrome, the t.co short link never gets converted into the real link and every time a blank page is loaded… Any help with this?


#43

I can’t open bitly links. Please, help! :frowning:


#44

All working well yesterday now receiving the following when trying to open any links either on Twitter or those embedded in my personal blog: Safari can’t open the page [ANY TWITTER LINK] because Safari can’t find the server “t.co”. I’m running Mac OS X 10.9.1 on my main computer. I’ve just tried my iPad and iPhone and they’re not working either. The address bar on my iPad shows t.co and I get the message: Safari cannot open the page because the server cannot be found.

I’ve also tried opening the links in Twitter in Windows, via Bootcamp, on my old Mac and the same problem occurs. The t.co issue appears to be the issue but how do I fix this?


#45

I have been facing the issue since past 1 month. It happens when I am on wireless. Request for some help. Cannot open any t.co link…it just shows me a blank loading page. Happens across all devices. Not restricted only to Apple.
Am not a techie guy . Would appreciate some help in layman terms :slight_smile:


#46

I have a similar problem to @secretnatureuk . I can’t open any t.co / bit.ly link on any device. I’m using Chrome, but I’ve tried it in Firefox and Internet Explorer. Nothing works. I’m not using any https forcing extensions.


#47

I haven’t been able to visit t.co links for at least a year. Actually I see all Twitter links are wrapped in t.co now, so let me rephrase that: there have been t.co links that don’t resolve for me many times over the last year. On my phone too, and before I got a router.


#48

This is odd - can you explain the behaviour you’re seeing? Could it be a DNS issue?


#49

I can’t open any links in tweets on my Mac. I have tried to open links from Chrome, Safari, clicking directly from Twitter.com/Tweetdeck/Hootsuite and all I get is a blank page. The only way way for me to access such links is on my iPad on iPhone.

How can I correct this. I am not very technical so please bear this in mind when you respond. Thank you


#50

Andy, I recently got a Macbook with OS X Mavericks. Since I got this computer, no t.co or other shortened links on Twitter have worked for me. Other non-shortened links do work though. I am using Chrome Version 36.0.1985.143. I have explored the internet about this problem but this is the only thread that has any kind of information and it’s still not helpful. This is extremely frustrating and I would appreciate any tips or help you can give me. Thank you.


#51

when you say they don’t work, what is the result - do you get a blank page, an error, or what?


#52

The page that comes up says:
“NO DATA RECEIVED
Unable to load the webpage because the server sent no data.
Error code: ERR_EMPTY_RESPONSE”


#53

I have a similar problem and it is frustrating.


#54

My t.co links never used to work…when it did recently work (or that’s what I thought) , it directed me straight to playstore with lot of unwanted sites getting opened up. Any help ? This problem exists for both - on my phone (Android) and my i-Pad (iOS7)


#55

I cannot open any t.co or bit.ly links on my computer in any browser. I can’t figure out why this is and it’s enormously frustrating. The links will open on my phone though. On my computer, the error message I get in Chrome (latest version) is “no data received”


#56

T.co and bit.ly links will not open on any browser on my computer. My browsers are all the latest updates and I’m not having DNS issues, nor is it an https issue. The error message I get in Chrome is “Data not received”.


#57

This has been an ongoing concern for me for the past year. Every t.co link fails every time, this is not an intermittent fault. Puzzlingly it only fails when using a mobile network and works reliably over wireless.

Attempts to resolve the link either hang with no response, or eventually fail with 504 Bad Gateway Timeout.

So far I have tried:
3 phones, 4 OS/versions (iOS, 3 versions of Android), 3 browsers, 2 mobile networks.

Other link shorteners (bit.ly, p4k.in, etc) all work flawlessly—only t.co links fail.

Any assistance will be appreciated.


#58

Which mobile network(s) is this failing on?


#59

Most recently Telstra and Virgin/Optus networks in Australia.


#60

thanks - this gives us something to go on.

Does the t.co domain resolve correctly on Telstra / Virgin/Optus DNS? Obviously I’m not located in that region so I cannot check for myself easily.