T.co links not working


#21

All t.co URLs have been broken for me for over a day. I’m on a Mac running 10.8.2, and have tried using Google’s DNS service, flushing my DNS cache (sudo killall -HUP mDNSResponder), and restarting my computer and router. It seems unrelated to the web browser I’m using:
$ curl -v t.co

  • About to connect() to t.co port 80 (#0)
  • Trying 199.16.156.11…
  • Operation timed out
  • Trying 199.16.156.75…
  • Operation timed out
  • couldn’t connect to host
  • Closing connection #0
    curl: (7) couldn’t connect to host

    It seems to work fine from other devices on the same network (such as my iPhone). Is there anything else I should try?

#22

having exactly the same problem. It doesn’t appear to be a DNS issue since I’ve tried a couple of options. It looks like it is limited to MAC hardware somehow. I’ve tried multiple browsers as well. Running OS 10.8.2 I’m amazed that this issue persists without any resolution.


#23

Finally solved this problem which has been incredibly frustrating. It seems to be both a DNS issue and something related to mac hardware as well as my PC on the same network was fine. I had changed the DNS on my mac but still had the problems. Had to go into the airport/time capsule and use the utility to change the DNS on the router. I’m using Google DNS 8.8.8.8 without any problems now.


#24

For the sake of following up: rebooting the Airport Extreme (between my modem and my Mac) seems to have fixed it, at least in conjunction with some/all of the steps above :slight_smile:


#25

No it’s not. Or it has resurfaced…


#26

yes, I want to know what is going on with this. it is incredibly frustrating. I click on a link and open it in a new tab. when i look at the new tab it merely shows my twitter timeline. it hasn’t re-directed so if I have not noticed it has happened, I have to search for the link again on whatever tweet i followed it from and if i was using a dynamic search or something, then what chance do I have of finding it again?
it is ridiculous that the actual t.co URL is completely lost and it doesn’t resolve into the correct page.
if I am unlucky I am left with zero recourse. if I am lucky, I can remember what the link was described as and I can locate the original tweet and re-open it. even then it takes up my time and is a drain on ‘productivity’.


#27

i am having the same problem everyone here is having today 1/8/13 and it has been going on for well over 2 weeks time. Called AppleCare all is clean and apparently swell with BigMac and LittleMac. I get the t.co in a tiny bit of blue and a blank white screen and that is it every time i click on a link in my time line.

i have Mac OS X Mountain Lion and thinking i may try rebooting the airport/time capsule and my router and see if that does anything


#28

I’m just wondering if twitter have any plans to sort this thing out?
I just opened 8 links from my twitter search. due to a network outage, the pages didn’t load. I reconnected and hit refresh and every single tab loaded to twitter.com. what use is this? each of the links I had opened, were completely lost. the search i had performed was no longer available since it was a very complex search and i had scrolled through various pages.
My productivity today has been utterly destroyed by this stupid link shortener.
all my research has been utterly lost.
WHY DON’T YOU FIX IT??? if the t.co url is referring to a specific page, then the page should be reached when i press enter on that url. there is no reason why it should not resolve. what you have created is a broken system.


#29

I am also suffering from the problem described above, running a Windows XP and Firefox. My browser attempts to load the shorthand t.co address and fails.


#30

This happens for me as well and I think it’s related to Apple’s Time Capsule. It only occurs when I am on wireless (connected via Time Capsule as a base station).

My firewall shows SYN packets coming back from the 199.16.156.x addresses:

10:45:14.085547 IP (tos 0x10, ttl 64, id 48993, offset 0, flags [DF], proto TCP (6), length 64)
192.168.2.109.63900 > 199.16.156.75.www: Flags [S], cksum 0x809b (correct), seq 4099635294, win 65535, options [mss 1460,nop,wscale 4,nop,nop,TS val 655950385 ecr 0,sackOK,eol], length 0
10:45:14.173431 IP (tos 0x38, ttl 47, id 0, offset 0, flags [DF], proto TCP (6), length 60)
199.16.156.75.www > 192.168.2.109.63900: Flags [S.], cksum 0x62e4 (correct), seq 1644745556, ack 4099635295, win 14480, options [mss 1400,sackOK,TS val 1841845037 ecr 655950385,nop,wscale 8], length 0

But the return ACK never reaches my computer.

Restarting the Time Capsule fixes the issue for a while and then it returns.

This affects everyone connected to wireless on the Time Capsule at the time that it’s occurring. Plugging in via cable directly to our network (bypassing the Time Capsule) causes t.co links to start working fine.

I can also ping the addresses, and do a UDP traceroute; just a TCP connect to port 80 fails.

$ ping 199.16.156.11
PING 199.16.156.11 (199.16.156.11): 56 data bytes
64 bytes from 199.16.156.11: icmp_seq=0 ttl=242 time=92.944 ms
64 bytes from 199.16.156.11: icmp_seq=1 ttl=242 time=92.929 ms
64 bytes from 199.16.156.11: icmp_seq=2 ttl=242 time=92.917 ms

$ traceroute 199.16.156.11
traceroute to 199.16.156.11 (199.16.156.11), 64 hops max, 52 byte packets
1 192.168.2.12 (192.168.2.12) 3.679 ms 1.017 ms 0.654 ms
2 178.255.65.98 (178.255.65.98) 1.366 ms 1.573 ms 1.474 ms
3 93.191.34.186 (93.191.34.186) 57.069 ms 2.216 ms 1.524 ms
4 ge-6-1-181.car2.london1.level3.net (212.113.8.165) 2.214 ms 2.081 ms 2.180 ms
5 ae-1-51.edge4.london1.level3.net (4.69.139.74) 2.266 ms 2.096 ms 2.249 ms
6 twitter-inc.edge4.london1.level3.net (212.113.14.238) 2.270 ms 2.083 ms 2.191 ms
7 xe-1-2-1.iad-cr2.twttr.com (199.16.159.125) 76.858 ms 77.241 ms 82.939 ms
8 ae50.atl1-er2.twttr.com (199.16.159.71) 89.802 ms
ae53.atl1-er1.net.twttr.net (199.16.159.75) 89.906 ms
ae50.atl1-er2.twttr.com (199.16.159.71) 90.039 ms
9 199.16.156.11 (199.16.156.11) 89.628 ms 89.146 ms 93.276 ms

$ nc -v -w 5 199.16.156.11 80
nc: connect to 199.16.156.11 port 80 (tcp) failed: Operation timed out

So it looks like something on the Time Capsule network/wireless.


#31

Having the same problem here and not easy to change the Time Capsule settings when at work and sharing the network. Any other suggestions?
Thanks


#32

i’m also have the same problem, the original links are instagram links but when I feed them into my app they turn into t.co links which dont work


#33

It doesn’t work for me either. Does Twitter care? this has been going on for almost a year and now answer!


#34

I had the same problem, t.co didn’t load at all… it just opened a blank page, refreshing didn’t help. Even copy/pasting a pic.twitter.com address redirected to t.co, and then failed to load. It turns out that in my case, an outdated Firefox extension was the culprit. I updated Disconnect ( https://disconnect.me/ ) and now it works fine.
(Firefox 19.0.2 on win7 x64)


#35

If you have this issue with Chrome, make sure you’ve disabled HTTPS Everywhere or any similar browser extensions that force HTTPS. Any t.co links (sadly) do not natively support HTTPS and will probably time out. In my opinion, this less of a technical problem and more of a privacy concern, especially if using Twitter over an open/public network. I haven’t tested this with Firefox, but I’m sure similar browser extensions would yield similar results.


#36

Disable ad blocking software such as Ad Free or Ad Blocker on your phone. In my case I disabled Ad Blocker that came with ROM Toolbox Lite (Android ICS). Restarted the phone and the links started working.


#37

Hi, today i have the same big problem for each link i try to click into the twitter post; the page return me this problem:

“Time for the connection timed out.
T.co The server is taking too long to respond.”

Please, what can i do to solve?
Thanks,
bye


#38

same problem here - no time capsul. no wifi.

ping t.co
PING t.co (199.59.150.44): 56 data bytes
64 bytes from 199.59.150.44: icmp_seq=0 ttl=247 time=222.242 ms
64 bytes from 199.59.150.44: icmp_seq=1 ttl=247 time=222.163 ms
64 bytes from 199.59.150.44: icmp_seq=2 ttl=246 time=224.718 ms
64 bytes from 199.59.150.44: icmp_seq=3 ttl=247 time=222.079 ms

traceroute t.co
Warning: t.co has multiple addresses; using 199.59.148.12
traceroute to t.co (199.59.148.12), 64 hops max, 52 byte packets
1 192.168.0.252 (192.168.0.252) 0.442 ms 0.212 ms 0.188 ms
2 * * *
3 * * *
4 * * *
5 *


#39

Same problem but new with OSX Maverick. Links OK on IOS7. This is major flaw.


#40

But it’s OK on another machine using OSX Maverick. Will add if difference between them found. It could be Time Machine, the Mac that is working is not connected.