Summary/large image validation failure with WARN: No metatags found


#1

For http://mcldaz.org/custom/kids.aspx I have added the metadata tags but it fails in both the validator and when I try to post the URL in a tweet. I’ve added a wildcard accept robots.txt, tried curl with the Twitterbot user agent and the page is sending back a Content-Type: text/html; charset=utf-8 header. I’ve even tried pasting in card meta tags from another site that works properly and it still won’t pick them up coming from this domain.

Any assistance would be appreciated.


#2

I see this on a verbose curl call.

< Content-Type: application/xhtml+xml; charset=utf-8

So I’m not sure that you’re correct in stating that the Content-Type is text/html?

I also ran the site through the w3 validator and it seems to be a bit confused as to whether it is XHTML or HTML. The key thing here though is that the Cards validator will ignore the content if the Content-Type is not one that it recognises.


#3

That’s interesting - Chrome’s Developer Tools is what showed me Content-Type: text/html; charset=utf-8. When I do curl -I I see the same headers that you do. This software (that I did not write) must be doing some sort of yucky user agent sniffing - I know it redirects the Google crawler to the mobile site automatically. It also doesn’t surprise me that the page doesn’t validate. :cry:

I was able to override the content type header by manually specifying it in the ASP.NET Webforms <%@ Page %> attribute section and now it seems to be working!

Thanks for your response, Andy!


#4

Great to hear, glad you’re all set.


#5

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.