Summary Cards Wont Display. I GIVE UP!

wordpress

#1

I’ve followed all directions and applied any advice I can find and my cards simply will not display. I’m at a loss. This seems very straight forward, but for the life of me I can’t get anything but the default gray card to display.

Here’s my meta data pulled from the source of my page.

<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:site" content="@lukeslytalker" />
<meta name="twitter:creator" content="@lukeslytalker" />
<meta name="twitter:url" content="http://natebal.com/blog/content-writing-advice/" />
<meta name="twitter:title" content="Content Writing Advice for Building Website Traffic" />
<meta name="twitter:description" content="(Visited 100 times, 1 visits today)" />
<meta name="twitter:image" content="http://natebal.com/blog/wp-content/uploads/2015/12/content-writing-advice-6.png" />

Here’s what I’ve tried…

  1. I completely removed my robots.txt momentarily to see if there was an issue with that.
  2. I scanned my .htaccess file to see if any ips in the Twitter range were blocked. They weren’t.
  3. I turned off card options in the Yoast SEO plugin.
  4. I have no other plugins running that do anything with Twitter cards.
  5. I’ve tried creating several new posts in case older posts were cached by Twitter.
  6. I created this thread 4 days ago but haven’t gotten 1 response. - Help with Twitter Summary Card Image Not Displaying no Matter What I Try
  7. I’m currently trying to get my card pulled using the Twitter Meta Plugin, but they can’t provide me any advice as far as what I need to do to get this working.

Can anyone provide any information? I’m officially tapped for ideas on how to make what sounds like very straight forward programming work. It’s frustrating as the great majority of links I submit to Twitter pull the correct info. It’s not rocket science, but I can’t seem to make my cards pull.

Am I waiting for Twitter to whitelist me? If so why does it say I’m already whitelisted?

Am I waiting for Twitter to purge their cache? If so why do my new posts still display the default gray image?

Does Twitter just not like me?


#2

Helllooo…Is anybody out there?

I just ran a link through the Card Validator and am still getting the default image. Looking for some help. I truly don’t know what I’m doing wrong. Lil help anybody???


#3

The only thing I can see that might cause this is that your image link hits a 301 redirect if I curl -v to the URL. That could be confusing the validator.


#4

I’m not sure what you mean by curl -v.


#5

I just updated my template. I uninstalled the Twitter Meta Tag plugin and am using Yoast for Twitter meta. My code looks like this.

<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:description" content="Step by step directions to fix structured data errors for better Google results. Eliminating these errors will help display rich search features." />
<meta name="twitter:title" content="Fix Structured Data Errors for Better Google Results" />
<meta name="twitter:site" content="@lukeslytalker" />
<meta name="twitter:image" content="http://natebal.com/blog/wp-content/uploads/2016/02/fix-structured-data-errors.png" />
<meta name="twitter:creator" content="@lukeslytalker" />

Now I’m pulling the correct meta info, but still no image. I’m starting to feel like Twitter is just screwing with me.


#6

Is anyone having the same issues as me? This seems very straight forward, but here I sit at week 2 trying to get this working. At this point, I’m about ready to give up as it looks like everything is getting picked up.


#7

I’m not sure how you’ve configured your Wordpress installation to handle images, but here’s what I’m seeing (as if I was the Twitter Cards Crawler aka “Twitterbot”), taking that image above as an example.

If I run (at the command line)
curl -A Twitterbot -v http://natebal.com/blog/wp-content/uploads/2016/02/fix-structured-data-errors.png

I receive a response HTTP 301 that the file has been permanently moved to another location.

If I then add -L (follow redirects) to my curl command
curl -L -A Twitterbot -v http://natebal.com/blog/wp-content/uploads/2016/02/fix-structured-data-errors.png
I get back a bunch of HTML rather than a PNG file, which I assume is a Wordpress page containing the image in a pretty manner.

So, our crawler never gets to the PNG file itself, which is why it is never displayed.

You’re right that this should be straightforward and I don’t usually see Wordpress users having this amount of difficulty with cards. I just tested my own site hosted on wordpress.com and the images are served correctly. I’m sorry you’re so frustrated.

I don’t know whether it will make any difference, but we have our own Wordpress plugin which you could try as an alternative to the ones you’ve tested. I suspect this is somehow related to the way your site is serving the images, though.


#8

I’m having a similar problem with the validator.

My site, https://www.aleksandreia.com is whitelisted.

My robots.txt is not blocking Twitterbot. The “ERROR: Fetching the page failed because it’s denied by robots.txt” is simply not true. According to today’s ongoing logs, Twitterbot successfully fetched my robots.txt file today:

199.16.156.125 - - [17/Apr/2016:02:26:02 -0700] “GET /robots.txt HTTP/1.1” 200 5032 “-” “Twitterbot/1.0”

Yoast SEO markup is correct in typical page

https://www.aleksandreia.com/2016/04/07/travel-bans/

Twitter summary cards were working previously using Yoast SEO; now they’re not (same version of Yoast SEO). Activating and deactivating the Yoast Twitter option meta tags doesn’t kick start them into working again.

There’s really nothing more on my end I can do to solve this. Something simply seems to be broken in Twitter with respect to summary cards.


#9

I haven’t done anything in particular with how Wordpress handles images. Back in the day I would upload images via ftp, but now use the media library.

I don’t seem to have a problem viewing the image above at the url listed above. I can post this anywhere and it is reflected.

I’ll give your plugin a shot. I’m officially out of ideas of what else to try. I assume I’ll have to disable the Yoast plugin as well. I’ll give it a try, but am pretty sure I’ll be posting here again.

Fingers crossed.


#10

Well I’m back. I tried installing the plugin, but am running an older version of PHP.

The Twitter plugin for WordPress requires PHP version 5.4 or greater.This server is running PHP version 5.3.29 released on August 14, 2014.Plugin deactivated.

I’m going to have to talk to my host. Maybe this is why Twitter Cards haven’t been working all along…?


#11

Ok I just upgraded my version of PHP to PHP 5.4.13. I activated the Twitter plugin andypiper suggested. My site is reflecting the correct Large Summary card code when I view the source.

I tried tweeting 4 posts. They’re still not pulling my imagery. I have no idea what I’m doing wrong.

I’m about ready to throw in the towel and just upload images manually when I tweet as I have been doing. This sucks for anyone who finds my site as my imagery will not appear if they retweet.

Is there anything else I can try?


#12

Ok I give up.

I just created a brand new post. My metadata is displaying. I don’t have any conflicting plugins. I tried 2 separate twitter plugins to get these to work. I’ve tried using the straight up metadata in my header.php. I didn’t do anything special to the treatment of my images. I’ve upgraded my php 3 different times and tested and I still get that gray image that just pisses me off at this point.

I’ve been developing websites for over a decade. This code is super straight forward, but how or why it works makes no sense to me.

At this point, I have no other option than to believe Twitter has gone sentient and has something against me.

It’s so frustrating that this works for 90% of the sites I tweet. Unless anyone has any advice I’m done. Anything Twitter developers? I’m really at a loss.

Link to new post that’s still not working


#13

Did you ever get your Twitter cards working? I eventually gave up when the Developers didn’t have anything new to try.


#14

No. Immediately after posting this my site URL was de-whitelisted for summary cards, according to the validator.

Checking just now I see the main site URL is whitelisted again and the tags read fine, but any given post - that is, subsidiary pages - is claimed not to be renderable because it’s blocked by robots.txt. Meanwhile, Twitterbot roams my logs daily chalking up 200 success codes as it successfully crawls those same subsidiary pages, using bandwidth without any value to me.

To be frank, given this I’m not really much interested in Twitter anymore. I don’t Tweet directly much myself, and I get little to no traffic from it. I was hoping to fix this, but life is too short to spend on such things. I should probably strip the Twitter markup from the pages to speed loading and actually block Twitterbot to save bandwidth.


#15

DONE I GIVE UP

I didn’t even think about Twitterbot spam. They black-listed you? Or grey-listed I suppose?

I’ve totally given up on making this work. I do get a lot of traffic from Twitter, but I feel like over a month of trying to get cards working to no avail and no further advice that I don’t have time for this.

It really sucks as I’d like this to work for people who tweet my posts, but I’ve had enough irritation.


#16

I don’t know what they’re doing. I only know that what the validator is claiming refers to something other than the facts. At that point, my decision becomes one of whether I care more about Twitter than it does about itself. I don’t.


#17