Summary Card With Large Image - NO IMAGE - [SOLVED]


#1

Hi there, if anyone could help with this issue I would be very grateful. I am trying to get twitter cards working with my easyblog BLOG and after following a few posts regarding twitterbox and image size I am at a loss.

The images are accessible by twitterbot as instructed. Using fiddler to inspect traffic while validating the card I noticed this : “image_value”:{“url”:“https://image-proxy-origin.twimg.com/2/preview.jpg?t=HBhQaHR0cDovL3d3dy4ycGljdHVyZS5tZS9pbWFnZXMvZWFzeWJsb2dfaW1hZ2VzLzY5OS9iMmFwM190aHVtYm5haWxfYmxvZy10Yi1yYi5qcGcUoAYU8AEAFuKAhrmUUxEA&s=n16H6FjZ3MaaeJamkTtlz-Xa8ux2oON5v7KvX0_Ie1I",“width”:400,"height”:120}

Is this what could be causing the issue … IMAGE size? …
Here is the link for the article that I would like to twith with a large card summary :

Many thanks in advance
Pat

Pat


#2

You’re using a summary large image card, which does not require the twitter:image:width or height attributes. I certainly think that the image width you have there (1000px) is too wide for a Twitter card to render easily. The file size itself seems to be within the limits for a card.


#3

Hi there, thanks for the quick answer … I thought that too… but the image that is pulled is a resized version (confirmed with fiddler) I just changed the size of the thumbnail that is being pulled by twitter to 500 x 150 which is within parameters i believe… Also I noticed that data is being cached by twitter as fiddler shows me that an image with size 400 x 120 is being pulled … Any idea on how to force cache to clear?


#4

Correct, cards are cached for about a week - there’s information on the Troubleshooting Guide to help here.


#5

Ok i see… still the information is a little “sketchy” … why even if I add a parameter on the card validator it looks like twitter is still pulling the wrong image size… ?

{“type”:6,“key”:“photo_image_full_size”,“is_optional”:1,“image_value”:{“url”:“https://image-proxy-origin.twimg.com/2/preview.jpg?t=HBhQaHR0cDovL3d3dy4ycGljdHVyZS5tZS9pbWFnZXMvZWFzeWJsb2dfaW1hZ2VzLzY5OS9iMmFwM190aHVtYm5haWxfYmxvZy10Yi1yYi5qcGcUoAYU8AEAFoKN38SUUxEA&s=4m_7iglaKuu_A0gM3_NWJDpWnof2AUKOqVaaODxJZEw",“width”:400,"height”:120}},


#6

ok… GOT IT !! with the parameter it is actually working… I had to resize the image “source”. I am using Easyblog and the image pulled by twitter is the “Thumbnail” image. So setting this to the correct “proportion” in easyblog settings -> media -> thumbnail size it did the trick.

Many thanks anyways!! sometimes it takes a little external “pair of eyes” :slight_smile:


#7