Summary Card whitelisted, but doesn't appear when tweeting


#1

Hello,
My summary card was whitelisted today, however when I linked my URL with meta tags embedded, the summary card doesn’t appear in the tweet.

Tweet URL: https://twitter.com/BettingRant/status/778548656836317184

I’ve attached photos below:



#2

I just Tweeted this link and the summary card shows up correctly. Is this still an issue for you?


#3

Hi Andy,

It’s working now - does it usually take a few hours to go from whitelisted to actually being able to post the website card?

Thanks


#4

No, not usually, but there could have been a caching issue perhaps? glad to know you’re all set.


#5

Hi I’m having the same issue. We just added the card code to our site and when I ran a URL through the validator this morning it said “whitelisted for summary_large_image card” and displayed the card preview as I expected it to appear. And the log was all green and said

“INFO: Page fetched successfully
INFO: 14 metatags were found
INFO: twitter:card = summary_large_image tag found
INFO: Card loaded successfully”

But then when I pasted that same URL into a new tweet window and sent it, just the URL appeared in the tweet instead of the card. Why did the card not load in the tweet?


#6

Just to further clarify: the card did not load when I sent the tweet from my PC using either Tweetdeck or twitter.com. But I just tested on my iPhone using the same URL and the card did load. Do the cards only work when sent from mobile?


#7

The cards render when the Tweet is loaded in the timeline. They will not show up in the Tweet composer window on the web (but they may show as you compose the Tweet on mobile). Are you saying that the same link posted in a different Tweet from web and from mobile, does not render a card in one case, but does in the other?


#8

Yes.

When I composed and sent the tweet on desktop from either Tweetdeck.com or Twitter.com, the card did not load in the resulting tweet - just the URL did.

When I composed and sent the same tweet with the same URL on my iPhone, the card did load in both the preview window and the resulting tweet.


#9

So can you provide links to those two Tweets? The card should render in both cases, regardless of what client was used. The difference in preview behaviour is expected though.


#10

I had deleted the ones that didn’t load the card but when I just tried it again on twitter.com the card did load in the published tweet. As we just added the Twitter meta tags to our site today, could there have been a delay in them working in our tweets? Although the URL did work in the card validator.

It appears my issue is solved but I do have a couple other related questions:

  1. I use tweetdeck.com in Chrome browser (not the extension) on my Windows 7 PC to schedule all my tweets. When I create and schedule a tweet this way that includes a URL with cards, will the card display once the tweet has been published?
  2. Do I need to run the URLs through the card validator first before I tweet them in order for the card to load in the tweet? I have to do this with Facebook’s open graph debugger so that the info contained in the tags are cached in their system.
  3. Looking at the tweet I just posted from twitter.com in Tweetdeck, all I see is the URL and not the card. Do cards not load in Tweetdeck? The card does load when viewing on twitter.com.

#11

Cards don’t load in TweetDeck - they work in iOS, Android, and Twitter.com. It’s a common request for the TweetDeck team, I’m sitting right next to them as I type this! It shouldn’t matter if you use TweetDeck to schedule and post a Tweet though - the card will render in the final Tweet in the clients that support that display.

You should only need to check your site in the validator once for the domain to become whitelisted, after which our crawler will know to check for your markup and render the card.

Overall, we can do a much better job of explaining this in the documentation to reduce these common confusions, so I’ll make an effort to get involved in that the next time we are updating it!


#12

Thanks for your quick responses. I’ll keep using the cards and am sure I will figure it all out. But now I know where to come for help.


#13

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.