Statuses/update_with_media v.1.1 works, but no status text?


#1

Been following the instructions to a T here: https://dev.twitter.com/docs/api/1.1/post/statuses/update_with_media

But every time I upload a photo (with just has the status and media[] values in the multi-part form data) only the link to the new photo shows up and not the text that I sent in the status parameter. My request looks identical (as far as I can tell) to the sample given on in the docs, but I never see the status text on the newly created tweet.

What’s REALLY strange about it is that per the doc, status is required, so the rest api must be getting the status value from us or it would reject the request, right? But it goes through! :frowning:

Does that make any sense at all? Is there something obvious I can check for? I’ve tried on multiple accounts just to make sure it wasn’t one account that was messed up, but still no go. What could this possibly be?!?!

Thanks,
Erik


#2

Can you share an example of the code that you use or a capture of the POST body you’re sending (minus the actual image data?)


#3

i have the same error

this is my test POST body

–cce6735153bf14e47e999e68bb183e70a1fa7fc89722fc1efdf03a917340
Content-Disposition: form-data; name = “status”

this is test from twitter
–cce6735153bf14e47e999e68bb183e70a1fa7fc89722fc1efdf03a917340
Content-Disposition: form-data; name=“media[]”;filename=“media.png”
–cce6735153bf14e47e999e68bb183e70a1fa7fc89722fc1efdf03a917340
Content-Type:image/jpeg


#4

i tested , the api doc is wrong https://dev.twitter.com/docs/api/1.1/post/statuses/update_with_media

put pars status in url query pars and it will ok

PS: just put status in query url pars!