Ssl://twitter.com:443 error


#1

I run socialengine and am getting a ssl://twitter.com:443 error.

Any thoughts? the API has already been fixed to point to https:


#2

@blizzbook, we updated the patch article and it should work now. It was happening because the PEAR OAuth library was doing a ssl peer verification.


#3

Make sure that you continue to verify peers. If you aren’t verifying peers, then your SSL isn’t functioning correctly.


#4

im still having the same issue? whats the fix?


#5

found the solution at http://jung.socialenginedev.com/twitterissue.php


#6

That solution is still not correct.

You want to change your OAuth URLs to https://api.twitter.com/oauth/*-based paths – the api subdomain is important for future proofing your application.


#7

Worked on both local and live site. Thanks!


#8

Error Code: 06974f
twitter Login Problem


#9

I am using a search api but i am getting the following error i have created my app and i am using the correct access tokens please help me.

I/O error on GET request for “https://api.twitter.com/1.1/users/search.json?page=1&per_page=20&q=innovation”:peer not authenticated; nested exception is javax.net.ssl.SSLPeerUnverifiedException: peer not authenticated.

Thanks you.


#10

Sachin, this java error means that you are trusting the wrong set of certificates. The following article explain how to fix this: http://javaskeleton.blogspot.com.br/2010/07/avoiding-peer-not-authenticated-with.html


#11

Cannot connect to the real www.twitter.com


#12

impossibile connettersi a twitter errore ssl


#13

How to fix Cannot connect to the real twitter.