SSL Handshake Error


#1

Twitter cards recently stopped working on my site. I ran the pages through the validator and I’m getting the following error message:

ERROR: Fetching the page failed because SSL handshake error.

Is there any known fix to this issue? Thank you.


#2

Any luck on this?


#3

I haven’t used the Twitter Card validator before but it’s not working with my nginx-based server either. Does it use old school SSL3 or TLS1.0? Because I enabled those legacy (and broken) protocols.


#4

We’re experiencing the exact same error:

ERROR: Fetching the page failed because SSL handshake error.


#5

We’d need to see a link to an affected site before being able to help to debug the issue.

I realise this refers to Apache, but there’s a possible resolution here to similar issues, I don’t know whether it will help those affected?


#6

Has the issue been resolved or is there a fix to implement on the server hosting the website? We’re still experiencing the issue for our website: https://www.startyourbestdrive.com.

The cards validator returns “ERROR: Fetching the page failed because SSL handshake error.”

I ran our SSL Cert through Qualys SSL Labs and it received an A- rating. https://www.ssllabs.com/ssltest/analyze.html?d=startyourbestdrive.com&latest


#7

The post linked above suggests a fix / change to the Apache configuration which may help.


#8

The suggested fix in the link posted above was implemented when the SSL Cert was first applied. I reached out to our hosting provider and they confirmed that both the servername and server alias are setup correctly with the SSL Cert.

They did mention that they had to upgrade their DHE ciphers to 2048-bit to avoid the LogJam exploit (http://cloudsites.rackspace.com/important-notice-logjam-vulnerability/). As a result any application that cannot communicate using 2048-bit DHE ciphers will fail to connect to our system. Could this be the issue with the twitter card validator?

Any guidance would be greatly appreciated.


#9

Also I’m on a shared hosting environment (Rackspace Cloud Site) so I don’t have access to make any changes to the Apache config. I’m working with Rackspace tech support specialist to resolve the issue.

Is there anyway to find out what the exact error is that the Twitter Cards Validator application is choking on?
The error message “ERROR: Fetching the page failed because SSL handshake error.” is too generic and is making it hard to figure out what’s going on.


#10

I’m also having this same issue. Twitter Cards were previously working fine for me until after I went on a PCI Compliance binge and blocked all weak ciphers. Now when I try to validate a card, I just get the same SSL Error message that everyone here is reporting.

Can you Twitter people provide any guidance with a list of ciphers that are supported? I know your documentation says to use RC4, but that’s a PCI Compliance forbidden Cipher.