Spring XD issues - Need Help


#1

Hi Guys

I am using Spring XD to search and extract tweets on certain phrases. It was working perfectly 3 days ago. I managed to download 110 MB of tweets. But it stopped working 3 days ago. Desperately I created a new application and today used new keys and tokens. But its still not working ! Its not giving any message, neither does it come out or give any sort of out put. The XD Singlenode says its been deployed and deployed status complete. And the Shell says Stream has been successfully deployed.
This is the command I am using —

xd:>stream create --name MyTwitterSearch --definition "twittersearch --query='java, C++, C#, perl, python' --consumerKey='xxxxxxxx' --consumerSecret='xxxxxxxxx' | file" --deploy
Created and deployed new stream 'MyTwitterSearch'
xd:>

Anybody has any idea ? I have tried it in different machines etc. but they are all hooked to the net through the same wifi - I am told there are some sort of ip based restrictions in place …no idea whats going on.
Anybody faced similar situation ? Any help will be appreciated


#2

Are there any logs you can consult to find out whether there are any errors being thrown under the covers?