Some hashtags return no result


#1

I tried searching for some hashtags via search/tweets method. These hashtags return no result even though they appear on Twitter.com.

The hashtags I used are: #PutData2Work, #PutData.

Do anyone encounter the same issues with other hashtag? How can we fix this?


#2

I’ve just had a look for those terms on the website, and the most recent tweets seem to be in August and over 2 weeks ago.

From the Search API overview:

The Search API is not complete index of all Tweets, but instead an index of recent Tweets. At the moment that index includes between 6-9 days of Tweets.

So, my guess is that you’re getting no results in your API call because the index doesn’t include any within that time frame.

I’ve just tried another hashtag (#excited) which is more common using twurl "/1.1/search/tweets.json?q=%23excited" and that pulled back a number of results, so I conclude that it is likely to be the recency of the results that affects that call you’re making.

For more detailed historical search results we offer the Gnip service.


#3

Thanks. Time is the issue here.