Some card image not showing

image
cards

#1

Description of issue:
On some occasions, the card won’t show an image in the tweet, but it will in fact show in the validator.

URL affected (must be public):


Static image of the tweet, in case it changes in the meantime, and for future reference.
Capture

Troubleshooting steps attempted [note that we will not prioritise posts unless there is evidence of following the troubleshooting guides]:
All troubleshooting steps have been followed.
Most remarkable is that the validator properly shows the image.
I’ve explicitly taken a much older item, as I read somewhere that Twitter caches this image for about 2 weeks, but it also happens to more recent items.

We’ve detected that we may be sending out the automatic tweet too soon, and the image isn’t avilable yet. We’re adjusting this, but surely for such old items, it should have been corrected by now?


#2

Bump?

Surely the cache would’ve run out by now, if that’s the issue? Problem is still present.


#3

It looks like you are suffering the same issue I am. You have a CDN and twitter bots can not access your images. If you read up, you will find many other struggling with this. Its difficult to troubleshoot because twitter has a non developer friendly cache system, so once you fix it, it can take time to even know if you fixed it.

Apparently you need to add an allowance for twitterbot in your robot text. I have no idea how long after that it fixes. I have been waiting days and I am not sure if I fixed it or not. Hopefully someone with knowledge can step in with tips here.


#4

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.