[SOLVED] Reply to a tweet does not appear in target user's timeline

api

#1

I’m experiencing an odd issue when trying post a status update as a reply to a user’s tweet.

I have followed the instructions in the documentation to @mention the user’s screen name in the text of the tweet and also use the in_reply_to_status_id property. I actually get back a legit reply from the API which suggests that I posted a proper reply, but it does not appear on the mentioned user’s timeline.

Here’s the relevant part of the API response when posting the status update:

id_str: "a valid id"
in_reply_to_screen_name: "target user's screen name"
in_reply_to_status_id: 704991494340485xxx
in_reply_to_status_id_str: "704991494340485xxx"
in_reply_to_user_id: 85899xxx
in_reply_to_user_id_str: "85899xxx"

Any ideas?


#2

Sounds odd, are you able to share the specific Tweet IDs?


#3

Sure:

id_str: "704996704530120704"
in_reply_to_screen_name: "simonebu"
in_reply_to_status_id: 704996455682068500
in_reply_to_status_id_str: "704996455682068480"
in_reply_to_user_id: 85899046
in_reply_to_user_id_str: "85899046"

#4

I tried the same from the API console and didn’t work either, so at least it’s not related to my app but rather either something broken or something I’m doing obviously wrong.


#5

Ok solved. The problem was clearly on my side. The source user had its tweets protected.


#6