since_id parameter always throws 'invalid' error when calling favorites/list.json


#1

I’ve been writing a small app that involves pulling my latest favorites.

When listing favorites using https://api.twitter.com/1.1/favorites/list.json I get the last 20 favorites as expected.

However, when I try to pass in a since_id parameter on the URL, I am seeing the error code:
{ statusCode: 400,
data: ‘{“errors”:[{“code”:44,“message”:“since_id parameter is invalid”}]}’ }

I’ve tried using an obvious value like 1, I’ve tried using a nonsense value like 12345 (as specified in the docs), and I’ve also tried using an actual id like 283420447838711800

Each of them elicit the same response.

Here’s the code I’m using (Coffeescript in NodeJS) to call the resource:

getFavoritesFrom: (lastTweet, callback) ->
console.log “https://api.twitter.com/1.1/favorites/list.json?since_id=#{lastTweet}
@oa.getProtectedResourcehttps://api.twitter.com/1.1/favorites/list.json?since_id=#{lastTweet}’, ‘GET’, cfg.TW_ACCESS_TOKEN, cfg.TW_ACCESS_TOKEN_SECRET, (error, data, response) ->
if error
console.log error
callback 'Error: getting OAuth resource: ’ + error
else
callback data


#2

I get that error now, but only when I have a since_id of 0. Every other number (even the ones in your examples) work for me (but I’m using different calls).