Set Creative click url with http doesn't work

ios

#1

I set Creative’s clickUrl with a http web,when I click the creative in app,it doesn’t load success.When I used a https web as clickUrl,it works well. When I set a clickUrl,it must be a https web? What I do if it can use a http web?


#2

Hi,
I’m facing the same problem. I’ve found that the SDK is changing the http to https, so if the site you’re pointing doesn’t has https support it will fail.
I’m trying to find a way to prevent this behaviour.

Best,
Fede


#3

I edited the plist by adding NSAppTransportSecurity key of dictionary type with a dictionary element of NSAllowsArbitraryLoads of boolean type set to “Yes”.But it doesn’t work.


#4

@WillBetteM,

Adding the ATS exception would only affect the incoming traffic to your application (for example, an ad being served from the server to your app). As an FYI, iOS 10 would disable the ability to add this exception.

Coming back to the original issue, iOS has a strict mixed content policy, so if any traffic is served on HTTP, there might be an error. If you have control of the clickthrough URL (if it is exposed), you might simply stitch an s to the protocol before you invoke the clickthrough. Since UIWebView disables allowing mixed content, the best bet is to have the vendor enable HTTPS on their end as well.

Vu


#5

Hi @WillBetteM

Thank you for reporting this. If you don’t mind, can you please let us know the following:

  1. What MoPub SDK version are you using?
  2. Is this occurring on a specific device/OS?
  3. What is the http url you are trying to access?
  4. When you click on the MoPub ad, what specifically are you seeing or experiencing?

I’d like to dig deeper to try and figure out why you’re unable to have an HTTP link open properly. Regarding chauduyphanvu’s comment, were you able to have the vendor enable HTTPS on their end?

Thank you.