Set application type to browser


#1

Trying to implement ShareKit. ShareKit says to set the application type to browser, not client. Where do I do this?

Thanks so much1


#2

Hi John,

If you login to your “My Applications” page (I’m assuming you’ve already downloaded, installed, and setup ShareKit), you should change the ‘Application Type’ to Browser there:

You should set the ‘Callback URL’ to match what you input as your SHKTwitterCallbackURL as. I’d recommend also taking a moment to scroll through the docs over at ShareKit, as they have some notes around their integration with Twitter:

http://getsharekit.com/support/


#3

Sorry to be so dumb about this - I have a twitter app section - just don’t see a place to select “Browser.”. Under settings I have a section for Application Type which lists: Read, Read and Write, Read , write and access… I’m thinking this is why when my Twitter page comes up in ShareKit (my app), the top of the posting page is covered with a toolbar? THANK YOU!


#4

Not at all! Actually, we ended up just changing the UI with the relaunch so that this is no longer an explicit setting. In fact, as long as you specify a callback URL (which you do in the “Settings” tab of “My applications”), then you’ve implicitly set your application type as browser. Even if you’re callback URL is just a placeholder.


#5

thats good, now how do I set one for mobile ? my developer tells me I need two apps, one for browser and one for mobile ?


#6

Wow. Thank you I will definitely use this on my blog about natural alternatives to health and beauty - Rainbowluna.com This was a major stumbling block for me till I found this. Thanks


#7

please tell me How I can share images and tweets from android mobile here…
Thanks in Advance…


#8

shouldn’t you be using twitpic for that?


#9

Thanks @PrayForUs2010 and @jasoncosta this helped me too. There are tons of (old) posts out there talking about the browser setting, even the most recent ShareKit code. Will be good to get onto native Twitter support in iOS.


#10

I read all discussion but still struggling to find what does it mean Application type “Browser” i mean there is no option their to set as Browser, how can i change???
I have really bad English please reply in simple and brief… please its a request


#11

The language of setting an application type to “browser” is outdated and reflects a previous implementation of the system. You may find older documentation or articles by third parties still referring to this concept, but reality has changed.

If you want to set an application to what was once considered “browser” type: simply provide a URL in the placeholder callback URL field of the application. When a URL is in this field, your application is in browser mode. When there is no URL, it is not.


#12

please, can you write the exacly code that I need to write for use my application in a browser mode? thank you!


#13

thanks


#14

From the comments in SHKConfig.h:

“The callback url doesn’t have to be an actual existing url. The user will never get to it because ShareKit intercepts it before the user is redirected. It just needs to match.”


#15

How to set callback in code. x-authflow-twitter. What should i replace with all these three parameters. suppose on setting my dev account i have given https://www.google.com and my app name is accessapp. so what to write in place of “x-authflow-twitter”.


#16

@AkankshaR21 did you find any solution?