RWD permissions


#1

Hello,

i set my applications permission settings to RWD and even tried to set x_auth_access_type to ‘rwd’, ‘read-write-directmessages’ and ‘directmessages’ but all users who are authenticating allways get RW permissions.

Is there something else i have to change?

Please help! thx :slight_smile:


#2

You need to make sure you’re using the correct URL. If I remember right, you need to send your user to the /authenticate endpoint (vs. the /authorize one), otherwise you can only get the RW permission.


#3

i do redirect users to https://api.twitter.com/oauth/authenticate?oauth_token=[token]
and i’m pretty sure that ist correct (docs say so).

Anything else i could have missed?


#4

no, i mixed it up!
/authorize is the right one :slight_smile:


#5

Was just about to send you that… In my previous post I confused between the two. Sorry.


#6

Hi,

I just wanna set only two permission below for my application

  1. To Post Tweets
  2. See who users follow

Currently there are 3 options Read, Read/Write and Read/Write and Access Messages
But these three options doesn’t satisfy my needs…

Help me…


#7

Read/write is the permission you’re looking for. You want to “read” who users follow and “write” tweets. Our permissions don’t get more fine grained than that, aside from the additional “read direct messages” permission.