Restricting tweets count or apply filters when using twitter sample api




I am calling Twitter sample API “” to fetch the latest tweets via postman (used powershell too). However, the request gets stuck in “loading” state i.e. neither results get populated nor it throws any error.

I guess may be it’s happening because of the result size (a lot of tweets). So, I tried to restrict the results using count parameter but it is not working. Received the following error:
Parameter count not allowed in role statusSpritzer

Could anyone please let me know if the “loading” state is happening because of result size or some other issue. Also, is there any way I can restrict the number of tweets returned (based on some sort of sorting or just restrict the count somehow).

EDIT: I am able to access the sample API and get results (streaming) via program. However, the returned results are in random fashion. Please let me know if there is any filter or sorting logic provided by twitter sample API.



There are no parameters for the sample stream. You will, by definition, just get a random sampling of Tweets from the firehose.