REST API v1.1 not working with certain authenticated users


#1

Recently, I moved app id to V 1.1. https://dev.twitter.com/apps/1521979/show

It worked great except for two specific authenticated users.
With these, any query immediately returns 400: Bad Request.
e.g. https://api.twitter.com/1.1/statuses/mentions_timeline.json?count=200

We’ve tried everything we can think of, including getting them to remove and re-add access.
We even created a new App with a new Client Secret etc.
These didn’t work.
Our Oauth is fine - it’s been running for years, and it works when for other users.
The only thing that we can see that’s different about these are that they are both “Verified” by Twitter.
There’s not very much explanation of what effects being Verified means online.

Any suggestions or hints would be appreciated.
Heck, if we could just know why it’s being rejected, we’d be further ahead.

For privacy reasons, I did not post the client’s screen_name but get in touch with me and I would be happy to share it.
ward@nextanalytics.com or twitter screen_name: @nextanalytics


#2

Definitely interested in knowing the screen names on these – feel free to send to me via email: episod at twitter dot com

It’s very strange that you’re getting a HTTP 400 on this, as I’d expect to see if it was a user-specific issue in the 50X range. Do you get the same results if you request via the command line using curl or twurl or similar? Do all calls with the access token trigger the issue or just specific methods? Finally, does your implementation possibly consume and attach cookies with requests?

Thanks!


#3

Hello,

Thank you for your swift reply, but we found the issue. There was in-fact a bug with our software which we have rectified.

Thanks again :slight_smile: