Request token page timing out repeatedly


#1

Hey all, I am attempting to set up a twitter REST api application on the company site and have been having trouble just getting the request token. I’ve followed a couple tutorials on settings up a quick example app and have tried using the twitteroauth library and example code in attempt to just get the damn thing to work. I’ve went through the code line by line and it just simply times out on connection to https://api.twitter.com/oauth/request_token. I’ve passed all the required details and I’m just getting nowhere. So I assumed the twitter API/OAuth stuff must be down at the moment but I’ve seen no mention of it anywhere, am I only poor sod affected or have I completely overlooked something?

Chewing fingernails down to bloody stumps,
Rupert Sharp


#2

p.s I’m building the application on a LAMP environment (with latest PHP etc.)


#3

Hi @fitlads,

I’m not able to reproduce this lag on the request token endpoint. As a possible area to rule out, have you tried the request to http://api.twitter.com/oauth/request_token instead of the SSL-based endpoint? Are you able to issue requests from the same HTTP library to other API endpoints on api.twitter.com? What about other APIs?


#4

Oh I could crush a grape, that seems to have fixed it. I presumed you could only access it via SSL. The request must have been caught in the firewall %facepalm%. Righteo thanks for your help :smiley:


#5

SSL is definitely preferred, so you may want to create a rule in your firewall that allows for it.


#6

Agreed, I had just presumed it was already allowed =/