Request Approval button doesn't appear anymore


#1

I have implemented the standard twitter tags. Now the validator tool shows all green, all but one that is orange and there is no request approval button?

We requested approval before which was rejected and according to the email that I received we can apply again after fixing autoplay issue. We stopped autoplay and now card validator doesn’t show request approval button anymore all i see is this: *.buzzclue.com whitelist request rejected

and logs are:
INFO: Page fetched successfully
INFO: 29 metatags were found
INFO: twitter:card = player tag found
WARN: Not whitelisted

Here are few URLs:


How can we request another review? Can anyone please help.


#2

I just tried again on this URL: https://cards-dev.twitter.com/validator

Why request approval button doesn’t appear anymore? can anyone help on this?

example url: http://www.buzzclue.com/buzz/171897?video_id=216664


How to re-submit when it is not in whitelist?
#3

Sorry for the trouble here.

We have a bug in our validator we’re working on. I’ll reach out once the fix is deployed.

Ryan


#4

Thanks @rchoi


#5

Rchol,

Great to hear that there’s a fix in the works for the validator, and we’re not all crazy that the approval button just seemed to disappear… bad question alert: do you have an ETA for the fix? We have several campaigns on hold waiting for card validation.

Thanks! Whatever they pay you, it’s not enough :smile:


#6

Finally twitter has fixed the bug, i was able to submit my card. Thanks @rchoi


#7

Almost all good for me. I was able to submit my summary and photo cards but not my summary large image card. For some reason it just says “unable to render card preview” but with no errors in the log other than the site not being whitelisted. Anyone have any ideas why this might be?


#8

Are you able to share a link to the page you are trying to validate, or the meta tags you have used?


#9

It’s http://socialicity.co.uk/Link?linkId=59E9-1069

Hopefully that link will be ok. It’s possible someone might change the config at our end before you get to it and switch it to a product card though. Fingers crossed they leave it alone!


#10

It worked for me too. At first, I saw a preview error message but it’s working fine.


#11

@andypiper We’re so close now: three out of the four cards I want to use have now been whitelisted, I just can’t put in a whitelisting request for this summary large image card. Once that’s working we will be very happy indeed!


#12

@andypiper Any news? We’ve got clients that really want to use this particular card type.


#13

There are no card meta tags on that page, so there’s no way for the Cards Validator to render a preview.


#14

@andypiper you need to curl that URL or do something similar to see the page properly. The URL redirects to a page which has the meta tags on it but if you’re viewing that page with the meta tags in it in a web browser then there is a JavaScript redirect from there to another page without the tags. We already know the validator can read the tags on the appropriate page as it reads them fine for all other card types.

To recap: That url goes to a page containing the meta tags, If you’re in a browser though, you are forwarded by JavaScript to another page. You need to use something other than a browser to view the page.


#15

You’re right, my apologies - just did that with curl and I see the relevant tags.

Currently you have

<meta name='twitter:card' content='summarylargeimage'>
<meta name='twitter:site' content='Ladbrokes'>
<meta name='twitter:title' content='Ladbrokes Casino Deposit Match'>
<meta name='twitter:description' content='Join now for a deposit match up to £500'>
<meta name='twitter:creator' content='Ladbrokes'>
<meta name='twitter:image' content='http://socialicity.co.uk//Image/GetThumbnail/3396ba3f-ff42-45cd-8dd2-57237f995ea3'>

These look correct in the sense that you have a set of tags required…

One thing you need to change is summarylargeimage to summary_large_image to match the documentation on this card type. I’d also recommend updating your single quotes for double quotes - not required at all, but that would then be consistent with the rest of the code in the page :wink:

Try that change and see if you are able to get the preview rendered?


#16

@andypiper D’oh! Can’t believe I missed that. Thanks so much for your help, from what I can tell it’s going to work when I get this change published to our live site.


#17

The validation button does not appear after I have checked my two kinds of cards - I have previously asked for site to be validated

Am I in a queue somewhere?


#18

Thought I’d go on here as it’s more relevant - has Twitter sorted this problem out? I can get a preview of my card that claims everything is fine but no button for request approval


#19

I have a preview too but no request for approval button.


#20

same here. How should I proceed with new/edited cards?