Rendering when Firefox is used


#1

What needs to be changed to let Twitter deliver our tweets to our web site when clients use Firefox?

When people visit www.deltassist.com with IE the Twitter API delivers tweets pretty much as happened with the 1.0 API.

When people visit the same site using Firefox there is not box and it just says Tweets by @dfcseve

We have cut and pasted the script presented by Twitter again to confirm no typos or changes yet nothing is delivered by twitter. (Firefox ver 21.0 is being used) .


#2

Are you using one of our [node:10248]?

Do you see any relevant info in the Developer Console in Firefox when you receive the empty timeline?


#3

Hi,

We’re not aware of any issues with embedded timelines in Firefox, and I’ve just verified a few using Fx 21 myself. Could you possibly share a URL that you see not working? It’s sometimes possible that other scripts in the page can cause conflicts (although again, we’re not aware of any such issues at the moment.)

The other common issue that Firefox users have run into is Twitter JavaScript being blocked by ad-blockers, and so-called ‘Do Not Track’ extensions (which seem often to be overly aggressive in their treatment of script sources, rather than just enabling the standard feature.) Please check in your browser again with any such extensions disabled and see if that resolves your problem.

Thanks,

Ben


#4

Hi, I do have the same issue with Firefox 21.0. I discover the new api update so I follow the guideline to update to the new widget (a pity one with no way to customize the display, but it’s an other problem). The widget works on Google Chrome (can’t try on IE, because I am using Ubuntu).

I also update my google analytics script to be sure and remove a viveo video script who was in conflic with others js of the page.

My firefox has no special restriction and no blooking plugins. There is no display in firebug console window, so I have no way to found the source of the problem. Here is my blog address http://www.cedric-augustin.eu/ (the widget is inclued on the top right of the home page.

Hope this will help you to found the problem.


#5

I try with firefox on a windows 7 and it work’s. Maybe it’s related to the linux version ?


#6

I had a problem too with the widget not displaying in Firefox. I’ve just found the problem was caused by the latest version of Avast anti-virus, which was blocking the twitter widget by default in Firefox! The widget however worked OK in IE.


#7

I have the same problem and now some of my web clients are reporting it too. How did you solve it? Turns out that I have Avast Internet security