Redirection after authorization is not working


#1

Since last 6 hours, users of our app are not able authorize the application successfully. User gets redirected to Twitter.com for authorization, clicks on the authorize button, and then ends up on the page - https://api.twitter.com/oauth/authorize. Here the message “Redirecting you back to the application. This may take a few moments.If your browser doesn’t redirect you please click here to continue” keeps repeating, but the user does not get redirected to our webapp. Can someone from Twitter.com please look into this.


#2

I will like to add that the code on our end has not changed and this has been working perfectly for the past 2+ years.


#3

We made some recent changes to improve the OAuth flow as discussed here: [node:11538]

Are you setting an explicit oauth_callback on the oauth/request_token step? If so, what is it? If you aren’t – you should as it’s part of the OAuth spec.


#4

Yes, we were not setting that and were also using the old verify_credentials url - https://twitter.com/account/verify_credentials.json, which now is https://api.twitter.com/1.1/account/verify_credentials.json.

Thank you


#5

@episod I’m also having the same error. How should I set up an explicit oauth_callback on the oauth/request_token step. I’m a newbie in the OAuth . Can you show me a sample oauth/request_token.


#6

no


#7

Hi,
I have the same error also.
after I authorized the App. , I not able to found it in my App tab.
and (verify_credentials.json.) return to nothing
I’m using the local server (XAMP)


#8

I have the same issue here, this never happen before, so, i use this twitter application but whenever i sign in to twitter, my account keep being redirected, i click it and it says

“Whoa there!
There’s no request token for this page, That’s special key we need from application asking to use your twitter account. Please go back to the site or application that sent you here and try again; it was probably just a mistake”

But i don’t think it just a mistake because i keep repeating several times but don’t change anything, i already try with the other mobile twitter application, but still have the same result. So i doubt that was a bug from the application but twitter. Can someone please help me how to fix it? (Sorry for my bad grammar)


#9

Whoa there there is no request token …I have also issue