Redirect to base url not website


#1

In my Applications Details I have set my website as http://192.168.56.101/oauth/twitter.php
and my callback url http://192.168.56.101/oauth/example.php

when I go to http://192.168.56.101/oauth/twitter.php I get to the authorisation page for twitter, but when I get a redirect I go back to http://192.168.56.101/?oauth_token=xxx&oauth_verifier=xxx

Where am I going wrong? Why is twitter sending my request back to http://192.168.56.101/

Also, can I save the oauth_token and pass that to the API?

http://192.168.56.101/ = my localhost VM


#2

What are you setting as your oauth_callback during the oauth/request_token step? (You should both have a value stored in application details as well as explicitly declaring one on each request to oauth/request_token)


#3

Thank you, you were correct! I had $_SERVER[‘HTTP_HOST’] set up instead of the full URL.