Receiving 401 when retrieving request token


#1

I have my Consumer Key and Secret. I was able to retrieve the authorization request token. Recently, I started receiving this error:

“Authorization failed (server replied with a 401). This can happen if the consumer key was not correct or the signatures did not match.”

I have tried to reset my keys, but this did not help. I have since created another test application (with the exact same setup) and this works. My original application still does not work. I haven’t changed any of the settings of the application on Twitter from when it was initially working. My date and time are correct on all of my OAuth requests.


#2

We’re aware of an issue affecting the Your Access Token feature of dev.twitter.com - are you reading your user token and secret from that screen?


#3

Hello there,

Same as me almost, when a user try to authorize us to post to his account, or when we get a post to POST to that account, it’s not working… we get a 401 error.

Every thing was working like a charm…
What would be the error?

Regards…


#4

I’d like to add another note…
We have recently moved to another server, will that cause any issue regard authorizing or communicating with Twitter API ?


#5

Hi,

In an Android application, we were using a test account (created some time ago) and are now switching to a production account, that we just created.
But, with that new account we now get a 401 on request token. I checked the setting, and it’s read/write. Phone time is correct (network sync).

Are we missing something ?


#6

I’m also getting an error 401, not sure if this is a bug, or if I’m doing something wrong.


#7

401 Unauthorized: Authentication credentials were missing or incorrect. New basic account running wordpress and wp to twitter plugin. Have used this plugin on hundreds of sites we have built, but on this latest, no matter what we do setting up the OAUTH we get the above error… yes we have set it to read and write!!!

Why do you guys always make everything so difficult? Does anyone test, I mean really test, before you start making changes?

So what is the solution???

This site was built from a clone process that we have been using, it originally had a different twitter account set up and was working, until we tried to change it to a new twitter account and the newest convoluted authorization process!!!

This kills us consultants… We quote setting up wp to twitter and twitter goodies as part of a site build only to find out that getting twitter to work after an update is taking longer than the whole @$%!@#%@!# site build.

WWHHYY??

no decent help, just a lot of text explaining how the backend of the authorization process works for program developers, virtually nothing for those of us who simply want to interface a blog to theri twitter account…


#8

what solution,401, Authentication credentials were missing or correct.(‘error’. could not authenticate with oAuth. ‘request’ )


#9

We are seeing the same issue over here. We have an existing application that uses signposts java OAuth library to post requests to twitter. We have one application that was created a year ago that is working fine. We created a new application a couple weeks ago that uses the same code and when we reconfigured the application with our new Key and Secret we started seeing this exception when trying to obtain our access token.

oauth.signpost.exception.OAuthNotAuthorizedException: Authorization failed (server replied with a 401). This can happen if the consumer key was not correct or the signatures did not match.

I have a unit test that grabs the access token with both sets of credentials and our old one works fine but our new ones fail. We have reset our key and secret 3 time now and keeping see the same result. Any help would be appreciated


#10

hi i have the same problem.Authorization failed (server replied with a 401). This can happen if the consumer key was not correct or the signatures did not match.
same consumer key and secreat key is working fine with iphone application but when i use this with my android app it gives me error what is solution for that.


#11

Please start a new discussion and try to post as much information as you can - which library you are using, your authorization code, and HTTP dumps of the request/response if available.


#12

Same problem has been plaguing me for a long time.

401 Unauthorized: Authentication credentials were missing or incorrect.

Sorry! I couldn’t get in touch with the Twitter servers to post your new blog post. Your tweet has been stored in a custom field attached to the post, so you can Tweet it manually if you wish!

Using the latest version of wordpress, the latest version of wp to twitter and still getting this crap. Anyone solve this?


#13

Same problem over here, application was working fine until a week ago. I am allready using https also.


#14

WTF is wrong with the folks at twitter. Is anyone goung to provide a solution?!?!?

My app was working fine, I could even retrieve credentials so I could tweet through a new twitter account… however I was getting a 401 error when tweeting from my app through the new account. I logged into the twitter account and even through I granted my APP authorization (using the oAuth procedures, and retrieved the tokens on the trackback page, I noticed that the Application was not showing in the twitter settings page. I tried again and did not work.
I went to another twitter account that was working. I revoked the application in the settings. From the App I tried to get new credentials for the twitter acct. and successfully got them… however, the app was not showing in the settings page. I could no longer tweet from the App to this account.

Finally tried to reset the Apps consumer Key and Secret. Got new ones. ?Now when I hit the api.twitter/oauth/authorize? page I get a 401 error with the new creds (and the old ones too)


#15

Please start a new discussion thread with the exact error message you’re seeing, along with as much information you can provide (raw HTTP dumps of the failing requests would be preferable) along with snippets of the code which creates the failing request.


#16

New thread is at
https://dev.twitter.com/discussions/3610

same as…

I am using the following libraries for Android-Twitter integration
signpost-commonshttp4-1.2.1.1.jar
signpost-core-1.2.1.1.jar
twitter4j-core-2.1.11.jar

The error message is same as indicated at the beginning of the thread

“oauth.signpost.exception.OAuthNotAuthorizedException: Authorization failed (server replied with a 401). This can happen if the consumer key was not correct or the signatures did not match.”


#17

I had the same issue, hope this helps you:


#18

The solution is rather simple, all you need to do apparently is to place a website in the call back url field, any URL would do…Only way for it to work


#19

andstatus and andtweet suffer from this too.


#20

I have 5 web sites using the “Tweet This” WP plugin and I’ve always put a URL in the “call back” field and I still have yet to get the “Tweet This” WP Plugin to work on anyone of the sites.

I would like to know if it’s the plugin or Twitter? And how to get the plugin to work even once.