"Read-only application cannot POST" error


#21

Hi GiftPod,

Can you tell me where can I find if my account is already confirmed. I can’t find anything related on my settings.


#22

Adding to @theJusarg Justin Sargent’s summary, there was one other thing I had to do:

To solve this error make sure you do the following:

  1. You have confirmed your email with twitter
  2. You set you application settings to Read/Write
  3. You reset your keys/token
  4. WAIT - Took twitter a little bit to reflect the changes I made to my app, once it updated though it fixed the error (so give twitter an hour or so to update).
  5. Have OAuth-authenticated users log out of your app and go back through the OAuth login process

For some reason, after I did #3 and restarted my app with the new keys/token, my users who had gone through OAuth on the previous keys/token were still able to interact with Twitter with their previous OAuth credentials. It looked like I had done everything (i.e. steps 1-4) but it required having them go back through the OAuth process to get it working.


#23

thanks


#24

thanks for the answer …


#25

Make sure you “RESET KEYS” once you changed your app to read/write.


#26

I couldn’t set Access Level to “Read and Write” for Posting Status on Twitter.

Steps:

  1. Created an App
  2. Tried setting access level from “Read Only” to “Read and Write” by clicking on “Update Setting” button.
  3. Comes up an error saying
    "You must add your mobile phone to your Twitter profile before granting your application write capabilities. Please read https://support.twitter.com/articles/110250-adding-your-mobile-number-to-your-account-via-web for more information"

I then referred the URL provided in the error, but it still not allowing me to update my mobile number and says
"Sorry, we don’t have a connection to your carrier yet!"
Can anyone please help me with it or point me to the right direction?

Thanks
@hdvarde


#27

second that, same problem!


#28

This is the corrent answer guys, thanks :slight_smile:


#29

this was the key for me, now i’m all set thanks!


#30

Hi, May I know if you have resolved this? I’m also facing the same problem.


#31

This problem have been solved. It worked well with me, may be useful for you: http://www.webpreg.com/question/twitter-api-error-read-only-application-cannot-post


#32

This problem have been solved. It worked well with me, may be useful for you: http://www.webpreg.com/question/twitter-api-error-read-only-application-cannot-post


#33

This problem have been solved. It worked well with me, may be useful for you: http://www.webpreg.com/question/twitter-api-error-read-only-application-cannot-post


#34

Hello,

Im facing a similar problem but my application permissons always were Read/Write. The problem is that the tokens returned from the API only has Read-only permission Please, see this topic Token generated in the PIN-Based authentication has not the same permissions than the app

Thanks,
Aldo


#35