"Read-only application cannot POST" error


#1

Hi,

My application has been registered as read/write for about six hours but I’m still prevented from tweeting via the api:

“Read-only application cannot POST”

Any help appreciated, thanks.


#2

Did you regenerate access keys after upgrading your app?


#3

Thanks… The problem was that the email address I used for the parent Twitter account wasn’t confirmed


#4

Hi,

My application has been registered two hours before.

Here OAuth settings & Access Token Access Level is Read Only.

I got the this error, {“error”:“Read-only application cannot POST”,“request”:"/1/statuses/update.json"}

Can u help me where i did my mistake?

Thanks.


#5

You set your access level to read only, which means it can’t POST status updates.

You’ll need to set your application as read-write to POST status updates (and perform any other POST operations).

You’ll also need to renegotiate your access token so that it bears the upgraded permissions.


#6

Thank you dear. .

Its work well. Cheers…


#7

Thanks Dear


#8

thanks for the answer guys :slight_smile:


#9

I did put my site onto no posts for awhile, but it is now on posting…everything is again fine.


#10

Hi…
I had configured The python-twitter Api it done succesfully,
I can get the friend list from my acccount. but couldn’t update the status on that
I had set the application type : access as Read, Write and Access direct messages
but it could not working this error is occurred…

twitter.TwitterError: Read-only application cannot POST


#11

Thanks
I got solutions…


#12

still can’t post after upgrading my app, any help ?


#13

I am authorized OK but getting ‘Read-only application cannot POST’ when trying to set status.
I did set my app to Read and Write and hit update applications’ settings
I did Reset my Keys.
Any Ideas?


#14

Just working through my first tweepy application and was running into the same problems! Here’s what worked for me!

  1. On the ‘Settings’ tab, change your application type to anything other than ‘Read Only’
  2. On the ‘Reset keys’ tab, just reset your keys… not fun, but just do it
  3. Copy your keys from the ‘OAuth tool’ into your code

Mine took about 15 minutes to actually work, guessing its the twitter side of things gearing up for the changes but it worked for me!

Good luck!


#15

@samgutentag Thanks for the answer :]


#16

Thanks


#17

aha!


#18

(Summing up all the possible steps you can take to fix this error)
To solve this error make sure you do the following:

  1. You have confirmed your email with twitter
  2. You set you application settings to Read/Write
  3. You reset your keys/token
  4. WAIT - Took twitter a little bit to reflect the changes I made to my app, once it updated though it fixed the error (so give twitter an hour or so to update).

#19

Demora mesmo para o TT atualizar???


#20

thanks a lot