Read-only api issue - BIG PROBLEM


#1

Hi.
I’m having problems to generate a read and write key on twitter dev’s page.

Follows below what I tried to do (I am using google chrome):

  1. Generate the api;
  2. On settings I changed the acess to read and write - here occurs the first problem, first I changed the radio button to read-and-write and clicked on “UPDATE” the page reload but the acess was not changed, so I did it again and when reload the change takes effects.
  3. Go back to details and GENERATE acess token - it were marked as “read and write”;
  4. Go to my joomla! integration interface and put the information there;
  5. When validate occurs the error “READ ONLY KEY”;
  6. I tried to REGENERATE and it does not reflect on system, my token still the same.

Please, I need help to solve this.

Thank you
Elio


#2

Important to notice thar the key is marked on details od twitter dev’s page as read and write.


#3

The caching layer on dev.twitter.com can get stubborn. The best way to recreate your access token will be to explicitly revoke it on twitter.com/settings/applications and wait 5 minutes or so, then come back to dev.twitter.com to recreate the access token with the newly inherited permissions. Also, using the OAuth callback flow is another way to recreate a token.


#4

@episod thanks for your reply.

What you said did’nt work.
I dont know how to use the callback.

Any other idea?
tks!