"Rate Limited" after Temporary Write Privilege Revocation



About a week ago, I was notified by a few users of my Windows Phone application, UnfollowSpy, that parts of the app were no longer working. After looking into it, I found that the write privileges of the app had been revoked for some reason. So, I followed the steps of contacting Twitter to fix this issue. After a few days of back-and-forth with a mix of automated responses and (I think) human responses, the limitation was removed and everything began to work properly again. The automated responses notified me that my app had “violated” the Developer Agreement and Policy, Automation Rules Best Practices, Developer Display Requirements, and/or Twitter Rules. After looking through these documents, I could not find any part of my app that violated these conditions. However, I found one rule that could be easily mistaken to be violated: UnfollowSpy allows users to select multiple Twitter accounts to follow/unfollow and then batch follows/unfollows them. I can see how this can be mistaken for violated the automation rules, yet the follows and unfollows are not “automated;” every action is initialized explicitly by the user of the app.

I tried to ask if there were some way to appeal this possible misunderstanding, but I was again met with a haphazard mixture of automated and possibly human responses that addressed nothing in my inquiry. So, I figured I would let it be.

Now, a few days ago, there seem to be more issues with UnfollowSpy. Every read and write action returns with a “rate limit” error, even with accounts that have never before used the app. I know that there is no possible way that this is, in fact, a rate limit error, so I suspect that this may be in response to my “violation” of one of the many rulebooks, but since I could not appeal to this improper flagging, I have no way of remedying the problem.

I contacted Twitter Support through the email string from before, but again was met with an unrelated automated response that offered no insight on my situation. So, I was hoping that someone here would be able to help with the problem.

If you need any more information or clarification on the issue, please do let me know!

Thank you for your help,


Update: when I tried to create a new app on Twitter for testing purposes, I received another “rate limit” error from the application creation interface. Odd.

Anyone have any possible ideas on this?

Thank you!


I’m not familiar with your app directly, but what you describe would have been in violation of the following guidance:

You may not use or develop any application that allows for the following or unfollowing of user accounts in a bulk or automated manner.

That’s either bulk OR automated. What you’re describing sounds like a bulk operation.


This is due to a temporary and intermittent issue with app creation on apps.twitter.com - apologies, we are investigating.


Hi Andy,

Thanks for the responses. I must have glazed over that line; I’ll look into remedying that.

Do you think that the rate limit issues within the all could be due to this violation? Or is it also a temporary issue?

Thanks again,


The rate limit piece about creating new apps is a temporary thing.


Do you know anything about the rate limiting from within the app when performing read and write actions?



Rate limits are somewhat complicated as they differ across read and write operations. You can find information on the read operations on the rate limits page in the dev docs, but write operations are adaptive. This thread has some more discussion on the topic.


Hi Andy,

See my first post for more context. I’m receiving rate limit error messages, but I am sure that the errors themselves are not due to a rate limit being exceeded. And I’m wondering if this is another action taken by Twitter on my account.

Thank you!


I understand the question - you need to check on the rate limiting headers and endpoint to remain within the boundaries. If your app was suspended for some reason, the rate limits themselves should not have changed, but obviously you’ll need to correct whatever you did to fall outside of policy to get back to where you where. Again, for the endpoints involving write actions (update/create etc) you won’t get the same sets of headers as they are adaptive to reduce spam.


Hi Andy,

The odd thing is that the issue is not with rate limits; I simply receive rate limit errors. On the very first request for any account, I always get a rate limit error. I will look into remedying the violation of the guidelines in the next few days, but I am unsure if this violation is what is causing the “rate limit” error respoonses.

Any ideas?