Rate Limit


#1

Hi
I am using Twitter REST API V1.1. When I am trying to hit any REST API call I am getting error like “Error Consuming Twitter REST API.” How can I solve that?


#2

Hello,

Are you using a library to connect to the API? Did you make sure your calls are authenticated properly with OAuth?

If the issue is indeed coming from the rate limits, you can check the list of limits per endpoint, and our documentation for tips to avoid being rate limited.

Thanks,
Romain


#3

Hi Romain,

           Thanks for reply.  I have change my application's permission and regenerate all token.  After that I am getting error like "Could not able to Authenticate."  I check all token 2-3 times.  It's all correct.  I am using spring-social for authentication. 

Thanks
Naitik


#4

HI Romain,

    As per you "rate limit documentation" I can sent request after an hour.  (Am I understood correct?).  But for all requests I am getting error "Error consuming Twitter REST API. "

Thanks.
Naitik


#5

Thanks for the additional details. I just looked at Spring Social, in particular its code for error handling on GitHub. The generic message that you reported, “Error consuming Twitter REST API”, is coming from it and is a catch-all message for all issues non server/client, so I think your issue is indeed rate limiting.

Have you performed a lot of queries in the past hour? Have you tried with another Twitter app to make sure you authenticate properly?


#6

Yes, I waited for more than an hour and than I start to call REST API but It is giving me same error. I am sure that there is no problem with authenticate property because it was working fine till yesterday.


#7

Hi Romain,

     Problem solved.  There was a problem space in database in accesstoken.  Thanks for hint. :smile:

#8

Glad you got it all sorted out. Thanks for letting us know!