Rate limit Search API 1.1


#1

I have been working on changing to 1.1 API and have trouble understanding how the rate limits for the search api works. I am querying using oauth authentication via search/tweets as described in the API documentation. Problem is the headers are returning an Rate limit of 15 instead of the 180 call limit described in the documentation. Any idea what might be going wrong here?

Thanks!


#2

I’m unable to reproduce but that doesn’t mean it’s not happening to you. Is this consistently happening or you? What is an example URL that you’re executing? Are you performing OAuth via headers or via query string? What’s the value presented to you from this request before and after you’ve run queries?:

https://api.twitter.com/1.1/application/rate_limit_status.json?resources=search


#3

Thanks for the quick reply. I have only just today been encountering this problem. OAuth parameters are send via query string. I am using python library: https://github.com/sixohsix/twitter/. An example query is: https://api.twitter.com/1.1//search/tweets.json?count=100&lang=nl&q=test%20-RT&result_type=recent&since_id=276302484346114048&+all oauth stuff needed.

I have tried to get the rate limit status via that link, but it stays at 180 remaining calls all the time. For this reason i decided to check the headers instead, which shows the rate limit of 15 calls.

Thanks!


#4

Are you putting that extra “/” in the URL you’re actually executing or is that just a copy and paste error? I can reproduce this same issue by including the extra “/” in the path but not if I’m using the correct path…


#5

Oh wow, that actually fixed it! It always in the minor details…thanks alot :slight_smile: