Rate limit exceeded only on a specific IP

restapi
rate-limits
block

#1

Hello,

I have a set-up where I have an application that uses the REST API to retrieve tweets from lists that I made every minute or so. Since a couple of weeks no I’ve noticed that I get a rate limit exceeded up to a point where I thought…that sure is a long debounce… Then I ran the script with the same application keys on my machine and I got 200 response containing tweets, whereas on my cloud machine I got a “rate limit exceeded”… So obviously (?) that machine has been blacklisted/flagged/… I have no problem with lowering my “fetch” of tweets, but how do I go about getting my IP unblocked though… Any help is very much appreciated :slight_smile:


#2

These are limited per 15 mins intervals. If your IP was blackedlisted it wouldn’t download any of the info. You can draw the rate limit info from the xheaders to avoid this issue.


#3

Thanks for the reply, but I don’t think it’s a normal rate limit, if it was then indeed I’d be seeing at least some kind of tweets coming back in, but that’s not the case. For about 10 days on end, that same “rate limit exceeded” was returned. Then when I run the code on my machine, with the exact same credentials I get data back… Making me think that this is not just a rate limiting debounce or am I missing something?


#4

Whats the endpoint your using?


#5

The endpoint is /lists/statuses

And the strange thing is when I request the rate limit status I get this back:

“/lists/statuses”:
“limit” => 900,
“remaining” => 814,
“reset” => 1507643731,


#6

Wow I can see your nowhere near the limit. You will have to get confirmation of this from the twitter tech guys. However the IP twitter would log would be that off your server, and not the local machine. So I am guessing you load the same server via each device you use to access the API?

Try spacing the calls to every 15mins just as a test though.


#7

Yea I already stopped the polling of it entirely about an hour ago, I just retried to fetch tweets from 1 list, rate limit exceeded comes back. I’ll check with the twitter dev support then, thanks anyway!


#8

no probs good luck


#9

They have just replied (shout out and kudos to the support of Twitter!) and apparently our account was muzzled, I’m not sure why though… guess I’ll be reading the docs and policies again :wink: