Product Card Error: URL returned a 404 (twitter:image:src)


#1

I’ve tried both twitter:image and twitter:image:src yet keep getting the above 404 error (404 is typically a not-found error). The url is correct. The referenced page is a top-level php page, meaning it’s in the root folder. The image is in a subdirectory; noting just in case this is part of the issue; used the same configuration for our index page’s Summary card with no problems.

Image is the suggested 160x160 px.

Ideas?

meta info used

<meta name="twitter:card" content="product">
<meta name="twitter:site" content="@cbm1la">
<meta name="twitter:creator" content="@cbm1la">
<meta name="twitter:domain" content="cbm1.com">
<meta name="twitter:title" content="RETAIL PROPERTY LEASING &amp; MANAGEMENT for So. CALIFORNIA.">
<meta name="twitter:description" content="Helping clients lease, sell, find, and manage retail property in Los Angeles and surrounding California counties">
<meta name="twitter:image:src" content="http://cbm1.com/i/twitproduct2.jpg">
<meta name="twitter:image:width" content="160">
<meta name="twitter:image:height" content="160">
<meta name="twitter:label1" content="25 years in business, 1000s of spaces leased, currently listing 400+ in SoCal">
<meta name="twitter:data1" content="Retail Property Leasing &amp; Sales">
<meta name="twitter:label2" content="Tenant relations, lease admin &amp; renewals, property maintenance, property accounting, vendor management">
<meta name="twitter:data2" content="Retail Property Management">

#2

Hey there. Sorry about this, very frustrating! I’ve just tried your URL from here, and also tried accessing the image URL with our user-agent (curl -A Twitterbot http://cbm1.com/i/twitproduct2.jpg) and it seems to work fine, so I can’t figure out why the 404 is occurring. Your robots.txt looks good too.

The good news is that the large summary card you have for your homepage seems to be working great, I’m not sure why there’s an issue with your product card.

Have you tried using another image from elsewhere on your site in that parameter to see if there’s a way around the 404?


#3

I’ve now tried multiple different images, some of which are completely outside the recommended dimensions, just to see, and all return the 404 error???


#4

I’ve also tried both with and without image dimensions; no change: still the 404 error.