Product card : approved but not showing


#1

Hello,

My website has been approved and such pages should produce a product card :
http://annonces.budeal.com/animaux/JoM8xMd624

It has been approved and I received the email yesterday but the product card is not created in any tweet, see example:
https://twitter.com/Budeal/status/452812501567434752

Looking at the discussions I tried to the twitter meta in the beginning of the header but this is not solving the issue.
Can someone help me ?

Thanks !


#2

Sorry for the delay. I’ve looked at it too, and don’t see anything.

Going to bring to my eng team to investigate…


#3

At closer look, we’ve noted that the image itself has no content type:

-> curl -I http://files.parse.com/df0aed40-29e7-4228-88dc-b5d2a5e4b677/a2f4f38a-2c33-48b4-855b-e024f15abb6f-file
HTTP/1.1 200 OK
x-amz-id-2: hUXGAB9aZd3KR9IBry/hpZSe83aNPH73KHiqtjFkk9fcitPt8sEBV0a+90qv4/NA
x-amz-request-id: D0B2B6BBF75C987C
Date: Mon, 07 Apr 2014 05:44:41 GMT
Last-Modified: Mon, 24 Feb 2014 16:05:34 GMT
x-amz-version-id: WUoJhus7aIoJvxDnKG5fQ34_6A5C_a.5
ETag: "30eff7d0eb259d6a02c283315ba76b23"
Accept-Ranges: bytes
Content-Type:
Content-Length: 70022
Server: AmazonS3

Also, the image has no file extension either.

We’re not 100% sure, but correcting the content type would likely help. Is that at all possible?


#4

Hi, thanks for the answer. The data is generated through a Parse (parse.com) app.

I don’t think that I can add the extension to the image, I may be able to change the content-type but I’ll have to ask to the person in charge of Parse dev.

It seems that the file has a MIME type of image/png, if this can help…
Moreover, the image was properly displayed in the validator.


#5

Hello, @rchoi any news on the issue ?

I am trying to see how to set the content-type but it’s seems more complicated than I thought…

Thanks


#6

Hello, I tried a new test on the same page with an image with an extension and MIME type hosted directly in the same server as the website but it’s not working either.

You can see the link in this tweet :
https://twitter.com/Budeal/status/456406732365787136

Based on this I really think that the issue is coming from your side.

Please don’t hesitate to tell me if you need more information or want me to do more tests. Thanks !


#7

Any news on the matter ? Twitter cards are still not showing up.


#8

Sorry for the delay here.

I came back to test, but am getting 404s when loading the following URL:

http://annonces.budeal.com/animaux/JoM8xMd624

When it’s back up, please ping me at @rchoi and I’ll take a look.

Thanks!


#9

Hi, it’s now working.

It may be related to the fact that I am using Heroku and for the first tests the page was not responding quickly as it was hibernating. But now it’s working fine !

Thanks for your help.

Hope this can be useful for someone else !


#10

Thanks for the follow up! Glad it’s working now. phew