Problem with the Twitter-API-PHP maintained by @j7mbo

php

#1

Hi everyone,

I’m creating a new web application and I need to retrieve soma data by twitter(for example the profile image of an authorized user).
I’m using easyPHP DevServer 14.1 VC11, and when I try to run the default index.php in the library(I’ve right setted the keys) the browser shows me this message:

Fatal error: Uncaught exception ‘Exception’ with message ‘SSL certificate problem: unable to get local issuer certificate’ in C:\Program Files (x86)\EasyPHP-DevServer-14.1VC11\data\localweb\projects\progetto TIW\lib\twitter-api-php-master\TwitterAPIExchange.php:296 Stack trace: #0 C:\Program Files (x86)\EasyPHP-DevServer-14.1VC11\data\localweb\projects\progetto TIW\lib\twitter-api-php-master\index.php(39): TwitterAPIExchange->performRequest() #1 {main} thrown in C:\Program Files (x86)\EasyPHP-DevServer-14.1VC11\data\localweb\projects\progetto TIW\lib\twitter-api-php-master\TwitterAPIExchange.php on line 296

I hope someone could help me, because a read a lot on internet but no-one solve my problem(i tried to enable the “extension=php_openssl.dll” in php.ini but it still don’t work).

Thanks,

Diego


#2

It sounds like you need to update your php.ini config to point to a cacert.pem file.

Take a look at this thread on the Wordpress forums, for instance.

I don’t believe that this is an issue with the Twitter PHP library from @j7mbo itself.


#4

i am having the same problem not able to resolve it out not getting what exactly should i do…!!!
error
"Fatal error: Uncaught exception ‘Exception’ with message ‘SSL certificate problem: unable to get local issuer certificate’ in /opt/lampp/htdocs/Gesus/TwitterAPIExchange.php:305 Stack trace: #0 /opt/lampp/htdocs/Gesus/demo.php(21): TwitterAPIExchange->performRequest() #1 {main} thrown in /opt/lampp/htdocs/Gesus/TwitterAPIExchange.php on line 305"