Problem trying to sign in with Twitter using Twitter Async


#1

I am having a problem getting authenticate to work correctly. When I use Jaisen’s example start.php script on his server I am asked to authorize the app the first time. When I run it again, after the app is authorized, I am returned logged in immediately without having to approve the app. This is the correct behavior.

When I run the same script on my server against my app, I am asked to authorize the app every time. This is incorrect. I should be able to just sign in directly after the first run.

The code for Jaisen’s script is:

include 'EpiCurl.php';
include 'EpiOAuth.php';
include 'EpiTwitter.php';
include 'secret.php';
$twitterObj = new EpiTwitter($consumer_key, $consumer_secret);
echo '<a href="' . $twitterObj->getAuthenticateUrl() . '">Authorize
with Twitter</a>';

Jaisen says there used to be an app setting that told Twitter to allow user login. This setting no longer seems to be available.

Is there some way of enabling sign in with Twitter for an app now?


#2

That flag’s necessity in making this feature work has been factored out in recent times.

Ensure that that the value of getAuthenticateUrl() is returning https://api.twitter.com/oauth/authenticate?oauth_token=xyz and you’re explicitly providing an oauth_callback value to the previous /oauth/request_token step.

If a valid, active access token for your app does not yet exist for the user session currently active on twitter.com, the typical OAuth confirmation window should display. If a valid, active access token does exist, it should redirect after a few moments directly to your specified oauth_callback and you’ll then complete the sequence the same way you would have the first time, by exchanging the request token and oauth_verifier for the access token again.

The /oauth/authenticate endpoint does not support RWD permissions, but I don’t think you’re looking to make use of those anyway.


#3

Please tell me how to use twitterizer…
to access all details of users in my .net application using Username and password


#4

what is my username


#5

I cannot find the usual twitter page to login.


#6

I am experiencing a problem that sounds identical to the one in this article. In fact, my signon code snippet is identical to the one in this artical (but I am using my own app consumer_key and consumer_secret). I suspect we both copied from the same tutorial (http://webtutsdepot.com/2009/09/23/sign-in-with-twitter-example/).

I click my Sign in to Twitter button, it takes me to the Authorize an application page (https://api.twitter.com/oauth/authenticate). But, clicking the “Sign In” button only refreshes the authentication page.

As per Taylor Singletary’s reply, no, my authentication page url does not contain a ?oauth_token=xyz. Why not? Is the code me and Election Analysis are using incomplete? Does anybody have a solution to this?


#7

My getAuthenticateUrl() is returning https://api.twitter.com/oauth/authenticate?oauth_token=G595oQ3AwTy7SGaVMHqJEMxIF8mTRFooyen0Pwpm4I (of course the oauth_token varies).

But when I click the Sign In button, the Twitter authentication page refreshes, this time without the oauth_token query string. I am never redirected back to the callback url I pre-defined when I configured my app on the dev.twitter.com page.

B.T.W., my code is identical to that posted above.


#8

Solution:

Replace $twitterObj->getAuthenticateUrl()
with $twitterObj->->getAuthorizeUrl()


#9

yes,this is me


#10

same here: refreshes without query string


#11

I am using Epicurl method for sign in with twitter, I have face strange problem in twitter, In my domain IP address is “http://162.209.100.218” this its working fine but In domain name “http://garfum.com” not working both METHODS,
$twitterObj->getAuthenticateUrl() ,
$twitterObj->->getAuthorizeUrl()

" APP REGISTERED WITH DOMAIN NAME " please let me know what is the problem, Please anybody help me ASAP