Pre-like favorites not showing up as liked


#1

Has there been any resolution to pre-like favorites not showing up as liked either on the webpage or via the REST API?

If I visit my list of likes, none of them show up with the red heart. Requesting likes from the API doesn’t return any of these old favorites.

I do, in fact, like those tweets. Any way to get Twitter to list them properly?

Thanks!


#2

Soo, I tried to do this manually because it seems really hard to get a response from anybody. Now I’m rate limited and can’t even favourite a tweet anymore.

Please help, Twitter? Is there any way to reach somebody in support? I’ve also tried DMing with the support bot and sending a form request.


#3

+1 this is highly needed. I’m unable to access my likes from even 2 months ago.


#4

Please help, Twitter! What’s going on here?


#5

Bump. Can you please help, Twitter?


#6

Sometimes liked tweets randomly appear. Most times, they don’t. Is there any way to turn all of the old favorites into likes? Please?

58%20AM


#7

If you have a specific API question, it would help if you could provide a code sample, and the result that you are seeing that does not match your expectations.


#8

Hm, I’d hoped that the above was clear, but if not, my apologies. The core issue is that if I go to my list of likes on the webpage, the list is empty, despite saying that I have hundreds of liked tweets. These are probably all favourites from 2015 or before. You can safely ignore the API question if it makes diagnosing the problem easier since it’s reproducible from the webpage. (If it would help to have the API call that also produces the problem, I’m using https://github.com/bear/python-twitter to retrieve the likes).

Thank you for writing back! :heart:


#9

Here’s a screenshot of https://twitter.com/i/likes while logged in:

Every once in a while, an old favourited tweet will appear in that list. I have to re-like the old tweet, then un-like it so that it gets removed. I don’t know how to access the hundreds of other tweets that don’t show up.


#10

Hi Andy,

favorites/list isn’t showing nearly all of my likes. Any like I have from mid-December 2017 or before isn’t showing in the API. Here’s an example screenshot from my likes page. It seems like the likes are out of sync because you can see that although they’re on that page, the heart isn’t filled in. I imagine that might be related the API issue?

API URL used: https://api.twitter.com/1.1/favorites/list.json
Query string: screen_name=atlanticpdx&count=200&include_entities=true&oauth_consumer_key=REDACTED&oauth_nonce=REDACTED&oauth_signature_method=HMAC-SHA1&oauth_timestamp=REDACTED&oauth_token=REDACTED&oauth_version=1.0
API response: []
API response code: 200


#11

@andypiper I hope this thread has enough information for you to diagnose the issue. It’s still a concern. Thank you!


#12

It has a bunch of data but ultimately i am not sure it is an API issue and I believe the distributed backend and eventual consistency is likely to be the problem here. Sorry but I’m not sure we can help via these forums. Thanks.


#13

@andypiper Darn. Okay, thanks anyway. I really appreciate you taking a look. Is there somewhere more appropriate for me to bring this request? I wasn’t able to get a response from @twittersupport.


#14

Eventual consistency implies that the data should be consistent after a while. I deleted my recent likes using the API (favorites/list, then favorites/destroy) more than two days ago, now favorites/list returns [], while twitter.com displays over 9000 of my older likes.


#15

You’re right about that, but unfortunately I’m not able to comment on the discrepancy in terms of what may be shown on the web UI.


#16

Is there any avenue to report this bug on the backend? The @TwitterSupport account is completely unresponsive so I’m unsure what to do at this point.


#17

This is not a developer issue. You’ll need to engage the Twitter consumer support processes via help.twitter.com thanks.


#18