Platform.twitter.com/widgets.js is modifying global "define" var


#1

We use requirejs on our site which has its own AMD define function. It seems like recent changes to widgets.js have causes this variable to get overridden. Once widgets.js is loaded and define is change, modules are unable to be loaded by require.


Widgets.js is interferring with require.js
#2

it looks like this was fixed earlier today. though as https://dev.twitter.com/discussions/33914 it only happens when platform.twitter.com/widgets.js is included twice on the same page (you probably want to fix that)


#3

Thanks Micah and Josh for letting us know. This looks like a bug on our side. I’ll take a look at this soon.


#4