Platform and platform version targeting error


#1

Hi we have created a simple targeting to target android device and platform version cupcake, when we send this targeting to twitter we get this error

Can’t target platform ‘ANDROID’ and platform version ‘Cupcake’ together

So we tried with IOS and it’s platform version 4.0 and got this error

Can’t target platform ‘IOS’ and platform version ‘4.0’ together

The same happens when we tried this with twurl and your php scripts.

So is one excluding the other since on Twitter web tool you can target android and a specific version


#2

Hi @esome! I’ve just ran some tests and it seems that platforms and platform_versions are no longer accepted together, indeed. But you can send either android or version 1.5 - this works because the targeting_value of the platform version is different for android and for ios, so the platform version implies the platform.

Note: the Cupcake android version is the lowest android version supported by Twitter and you can omit it in this case.

@TwitterStaff: it would be nice if this was updated on https://dev.twitter.com/ads/campaigns/targeting.


#3

Thanks for the post, and we’ll work on the docs!