PIN authorization problem


#1

Hi guys,
My mobile application is not working now. I have issues with PIN authorization to Twitter.
It worked earlier this way:

  1. I make request : /oauth/request_token with parameters:
    Authorization: OAuth oauth_callback=“oob”, oauth_consumer_key=“my key**”, oauth_nonce=“1367998527”, oauth_signature=“my signature”, oauth_signature_method=“HMAC-SHA1”, oauth_timestamp=“1367998527”, oauth_version=“1.0”

    and receive HTTP/1.1 200 OK oauth_token=xxxxxxxxxxxxxxxxxxxxxxxxxxxx&oauth_token_secret=yyyyyyyyyyyyyyyyyyyyyyy&oauth_callback_confirmed=true

  2. I make request : /oauth/authorize?oauth_token=xxxxxxxxxxxxxxxxxxxxxxxxxxxx&force_login=true
    and receive authorization web page.

Then I input login and password there, press “Authorize app” button. Earlier, it redirects me to web page with PIN that user have to input in my application. But now it does not redirects me to this page with PIN…
Does anybody have same issue? How to get it worked?


#2

What happens on the redirect phase instead of being presented the PIN code?