Photo Card and HTTPS


#1

I got this error when using HTTPS url for twitter:image tag:

Fetcher internal error when pre-fetching image at https://yande.re/sample/0ec2b88bdf2d07112801b9c0e5ab9467/yande.re%20230127%20sample.jpg

Kinda ironic considering twitter itself requires full https but the fetcher doesn’t support https.


#2

We have some problems with certain https certificates, did you get it from GoDaddy? That’s one known issue we are working on fixing.


#3

Having this issue as well. Wildcard (*.n-sb.org) SSL via Gandi.net

URL: https://style.n-sb.org/s/merry-krampus


#4

We have similar issues.

We got error when using HTTPS url too:

Fetcher internal error when fetching page at https://movie.oshiraseapp.jp/movies/1

We use RapidSSL certificates via GoeTrust Global CA certificates.


#5

We are getting same error. We do have a GoDaddy certificate - assuming not fixed yet?


#6

We corrected intermediate certificates a few months ago.
We test your preview service, then it previewed certainly our sites and we don’t get errors.

https://dev.twitter.com/docs/cards/preview

Please check again.


#7

Same issue here - we’re using Rapid SSL from Geotrust.
We get error with https url but not with https.

Assume rapid ssl wildcard cert running into issue with Twitter? Any updates would be appreciated!


#8

We have the same issue, we use Rapid SSL from Geotrust.
Are there any updates on this?


#9

Can you provide a test URL for me to look at, and file a ticket if needed?


#10

sure, here you go:
works: http://d.pslot.io/tCID/preview
does not work: https://d.pslot.io/tCID/preview

thanks for looking into this issue


#11

@PassSlot,

When I look at that HTTPS URL, I see the following META:

<meta name="twitter:card" content="photo">

In particular, that image URL:

http://i.pslot.io/?url=http%3A%2F%2Fd.pslot.io%2FtCID%2Fpreview&selector=.passslot-pass&retina=1&sign=fdjtU0sgAT%2BH4ok9K3jLs2LnWz4%3D

Gives me this when typed into a browser:

Unauthorized

Do you know why this is the case?


#12

did you check that the url you paste into the browser has correct encoding? If you directly copy the link from the source code, then the URL is not correct because it contains &
The link you posted here does work for us, I assume & was automatically converted to &.
Invalid signed request to i.pslot.io give you unauthorized.

As far as we can tell the image is not a problem. We tried it with the card validator and it returns “Fetching the page failed due to an internal error.”. The non HTTP-S link does work without problems


#13

Are there any updates on this issue?


#14

Sorry for the delay.

As noted before, putting the image URL in the browser returns an Unauthorized. Not sure what other variations are worth trying, but my guess is that the Validator is requesting the URL in a similar way (non-HTTPS), getting the Unauthorized, and fails as a result.

Unless a URL can be provided that is publicly accessible and returns an image, I’m not sure what else I can try. If you have other URLs that are publicly accessible, let me know.

Thanks again, and sorry for the delay.


#15

Please find a sample with a static image (the photo card should show the twitter icon white on blue):

This one works:
http://d.pslot.io/sample
This one not:
https://d.pslot.io/sample


#16

I get this same error for a regular HTTP request for these links:
http://bit.ly/1dTtRmD
http://www.ploprotege.com/twitter.html

I have my robots.txt configured to allow access to that file and the associated image file. Any ideas? Here are the tags I used:


#17

Does not seem to be related to the problem discussed in this thread.
Validation of your urls works fine for us.


#18

Just randomly started working. Maybe the tool just had an issue this morning, thanks for taking a look anyways.


#19

Hi @rchoi

Could you verify the problem?

Would be great if you can keep us updated
Kind regards


#20

Still no update on this issue?