Permissions: Read-only App suddenly stops working after changing to Read&Write


#1

I’m working on an app that allows people to register and log in via Twitter oAuth.

Finally got it to work, it redirected to the callback url and everything was ok.

Then I decided to change app’s settings. Permissions were changed from Read-only to Read&Write.

The app stopped working. You know the stage where the Twitter oAuth popup opens, you enter your password, click Authorize and it shows you this message on a green background: “Redirecting back to the application. This may take a few moments”

This is what is happening when the app is Read-only. The moment I change permissions, I get this strange behaviour:

  1. The Twitter oAuth popup opens
  2. I enter the password
  3. It flickers and stays put, only instead of “Authorize”, there are two buttons: “Sign in” and “Cancel”
  4. No matter how many times I try to click on “Sign in” nothing happens. The popup window stays open and ignores the callback url.

Whenever I change permissions back to Read-only, it starts working correctly again.
I’ve also tried to reset the Consumer Key and Consumer Secret, but that doesn’t change anything.
Also tried to set permissions to Read&Write&Direct Messages. In this case it ignores the Direct Messages bit and on the oAuth window it still says that “This app won’t be able to read your direct messages”

Has anyone encountered similar problems? Is there a solution for this?
Thanks.


#2

Related to: https://dev.twitter.com/discussions/21281


#3

bump please :slight_smile:
still having the same issue and I’ve read every possible source looking for clues.


#4

This issue can be mitigated by using oauth/authorize instead of oauth/authenticate. At this time, there’s no way to work around this bug that arises for some apps when they transit permission levels while using oauth/authenticate.