Passing Interest through Targeting Criteria batch save

ruby

#1

I am trying to send Interests with my batch Targeting Criteria request. I have gotten age, gender, location and followers_of_user to work, but not interest. What am i doing wrong? My request to batch_save is a list of TargetingCriterias. Just sending the location works, but including interest gives me a BadRequest error -

[
{
            "account" => {
                    "client" => {
                   "consumer_key" => "x",
                "consumer_secret" => "x",
                   "access_token" => "x",
            "access_token_secret" => "x",
                        "options" => {}
        },
                        "id" => "18ce54jsgq3",
                      "name" => "Startup_Sticker",
                      "salt" => "04ebd8a0789acd268fbfa6f973376044",
                  "timezone" => "America/New_York",
        "timezone_switch_at" => "2017-08-12T04:00:00.000Z",
                "created_at" => "2017-08-13T22:57:58.000Z",
                "updated_at" => "2018-01-05T15:56:06.000Z",
                   "deleted" => false
    },
       "line_item_id" => "atck0",
     "targeting_type" => "LOCATION",
    "targeting_value" => "018929347840059e"
}
{
            "account" => {
                    "client" => {
                   "consumer_key" => "x",
                "consumer_secret" => "x",
                   "access_token" => "x",
            "access_token_secret" => "x",
                        "options" => {}
        },
                        "id" => "18ce54jsgq3",
                      "name" => "Startup_Sticker",
                      "salt" => "04ebd8a0789acd268fbfa6f973376044",
                  "timezone" => "America/New_York",
        "timezone_switch_at" => "2017-08-12T04:00:00.000Z",
                "created_at" => "2017-08-13T22:57:58.000Z",
                "updated_at" => "2018-01-05T15:56:06.000Z",
                   "deleted" => false
    },
       "line_item_id" => "atck0",
     "targeting_type" => "INTEREST",
    "targeting_value" => "2003"
}
]

#2

Nvm, its fixed. The issue was somewhere else.