Oauth/request_token returns blank response


#1

Hi all I have tried several libraries and code examples/tutorials in an attempt to get a ‘login with twitter working’. So far I have not been able to get past the first step in the authentication process, that is the call to oauth/request_token.

I have noticed that when things? are not properly formatted / constructed, this API endpoint generally returns the string ‘oob’. However when I am certain the request is well formed on my side, then the oauth/request_token generally returns a blank response with a success http status.

The most recent library I am using is codebird:
https://www.google.co.za/url?sa=t&rct=j&q=&esrc=s&source=web&cd=1&cad=rja&uact=8&ved=0CB4QFjAA&url=https%3A%2F%2Fgithub.com%2Fjublonet%2Fcodebird-php&ei=S6ZIVN7VINKv7AaS_oDQAQ&usg=AFQjCNGZsJO_exCzZaIGLPvrsc7RJTrAOA&sig2=fZlf0glargf_RIkRWvAkAQ&bvm=bv.77880786,d.ZGU

I am using this as it seems to be the most actively maintained.
Does anybody know whats wrong here?
PS I am using the codebird example code (obviously the NOT specify your own ‘OAuth token and secret’ code example).

Some more info: My codebird implementation is trying to make the following request:

URL:

https://api.twitter.com/oauth/request_token

Request headers:

Authorization: OAuth oauth_consumer_key="2tzFRY14BjdT0LtRsignOAaMK", oauth_nonce="62dbc463", oauth_signature="Dedk3tOz%2BeLK7VyshW0wfrHmtu0%3D", oauth_signature_method="HMAC-SHA1", oauth_timestamp="1414048969", oauth_version="1.0"
Expect:

The response is completely blank with a success http status, and as far as I can tell the response headers are also blank.

I have tried regenerating the consumer key and I have tried using the /1.1/ url as well.