Oauth problems with native twitter on ios5


#1

Some of our users fail to authenticate with oauth since they upgraded to ios5 and setup their native twitter account on their ipads.
It’s a strange problem cause the same user can login using different user credentials.

So, it seems like only some of the user accounts are affected.
We’re really stuck here - what could be the cause?


#2

To add more information about the issue:

It’s the oauth/access_token ("-1012 The operation couldn’t be completed) that fails for some twitter accounts. The same failing users are able to successfully login with another Twitter account. For some reason, some Twitter accounts are unable to retrieve the access_token. I’ve tried to change the Twitter app consumer key & consumer secret to no avail. Everything was working fine with iOS4.

Also, we can’t move to native iOS5 authentication yet because we need to do work on the server on behalf of the user. We are using the following libraries MGTwitterEngine and libOAuth (see https://github.com/bengottlieb/Twitter-OAuth-iPhone/tree/master/Twitter+OAuth/)

Any theories?


#3

Is this fixed? How to fix this?
I got the "-1012 The operation couldn’t be completed on ios5 device. But everything is fine on a none ios5 device.


#4

Anyone found a solution to this yet?


#5

I solved this by changing the urls in initOAuthWithDelegate in SA_OAuthTwitterEngine to use https instead of http. Fix is detailed at http://www.musicalgeometry.com/?p=1537


#6

I can log in via my iPad but not my iphone


#7

Hello,

If you go to the new iOS 5 twitter settings, in the settings menu, you can find your profile and delete the password from there. Click ok when it says your password is incorrect and then re enter the password there rather then on the actual app, it will then confirm with ticks. Then you can tweet again! :slight_smile:

Confirmed on iOS5 on iPhone 4.

Eric.


#8

Hello,

I cant log in my account via pc!