Not receving any events besides CRC check on my webhook

webhooks
account-activity

#1

Auth’d on our platform using the account I am posting this with.

Used my token to setup a webhook subscription using the documentation found at: https://developer.twitter.com/en/docs/accounts-and-users/subscribe-account-activity/guides/getting-started-with-webhooks

My CRC check is working correctly and when I do the “list subscriptions” endpoint I get a valid payload back like this:

[{:id=>“970816022759448576”, :url=>“https://3f0b3e59.ngrok.io”, :valid=>true, :created_timestamp=>“2018-03-06 00:19:11 +0000”}]

(since deleted)

But I’ve tried dming myself many times and also mentioning myself on twitter from a different account on both actions. The only request I ever get is the CRC request.

What’s up?


#2

I have an important update.

I’ve done some more digging today and this is to the best of my knowledge the situation:

We have access to the non beta (production URL). I can create subscriptions on /1.1/account_activity/webhooks.json without issues, just not receiving events.
I think the reason this worked last summer but not now is because the Account Activity API was moved into the Premium API category and put into a beta mode sometime last fall/winter.

We do not have access to the beta environment (‘env-beta’) for the following application IDs:

125311 – Our Production App
1467830 – Our Staging App

Let me know if there anything I can help with to make this process easier.


#3

Another quick update:

Reading this link (Was I given access to the Account Activity API (Standard)?) It says to run

twurl /1.1/account_activity/all/webhooks.json

to see what environments we have access to. When I run this with my personal account and authorizing with our production account I get:

{“errors”:[{“code”:200,“message”:“Forbidden.”}]}

We’re trying to scramble and replace User Streams so we’re very anxious to see some forward progress on this issue.